Bug 457567 - pulse not support monitor link on bond interface
pulse not support monitor link on bond interface
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: piranha (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Marek Grac
Cluster QE
:
Depends On:
Blocks: 460546
  Show dependency treegraph
 
Reported: 2008-08-01 10:56 EDT by Enzo
Modified: 2010-10-22 23:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:54:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to resolve problem (1.19 KB, patch)
2008-08-01 10:56 EDT, Enzo
no flags Details | Diff
revised mii fallback patch (993 bytes, patch)
2008-09-03 07:11 EDT, Bryn M. Reeves
no flags Details | Diff

  None (edit)
Description Enzo 2008-08-01 10:56:57 EDT
Description of problem:
With monitor_links enabled if the interface to monitor are bond interfaces the
monitor not work.

Version-Release number of selected component (if applicable):
The version of piranha used is piranha-0.8.4-9.3.el5

How reproducible:
- Create a bond interface on all server of cluster
- Create a cluster LVS with piranha and use a bond interface for public
- Pulse active on master server
- Pull out all cables of public interfaces on master server
  
Actual results:
Pulse not switch on slave node because is not monitor bond interface

Expected results:
Pulse switch on slave node

Additional info:
I attach the patch for resolve the problem.
pulse for monitor interface use SIOCETHTOOL but SIOCETHTOOL is not supported by
bond interface. I used SIOCGMIIREG when SIOCETHTOOL is not supported.
Comment 1 Enzo 2008-08-01 10:56:57 EDT
Created attachment 313206 [details]
Patch to resolve problem
Comment 2 Enzo 2008-08-01 10:58:15 EDT
I open also a "service request" on redhat

Comment 3 RHEL Product and Program Management 2008-08-28 11:12:09 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Marek Grac 2008-08-28 11:46:25 EDT
Patch is in CVS
Comment 6 Bryn M. Reeves 2008-09-03 07:11:30 EDT
Created attachment 315634 [details]
revised mii fallback patch

Revised mii fallback patch using system supplied linux/mii.h
Comment 7 Marek Grac 2008-09-03 08:47:34 EDT
Revised patch accepted
Comment 10 errata-xmlrpc 2009-01-20 15:54:51 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0095.html

Note You need to log in before you can comment on or make changes to this bug.