Bug 457644 - keep window open when it loses focus doesn't 'stick'
keep window open when it loses focus doesn't 'stick'
Status: CLOSED DUPLICATE of bug 477736
Product: Fedora
Classification: Fedora
Component: yakuake (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Johan Cwiklinski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-02 02:11 EDT by Claude Jones
Modified: 2009-01-09 11:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 14:53:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Claude Jones 2008-08-02 02:11:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1

Description of problem:
Yakuake always opens with the keep window open when it loses focus setting checked. I always uncheck it. The next time I open yakuake it is checked again. I seem to recall a provision to save settings in older versions, but, I can't find any such capability now. 

Version-Release number of selected component (if applicable):
yakuake-2.9.3-1.fc9.i386

How reproducible:
Always


Steps to Reproduce:
1.Start yakuake
2.Get into settings and uncheck the keep window open when it loses focus setting
3.Close yakuake and reopen it; the setting will be checked again

Actual Results:


Expected Results:
The setting should carry over to the next time I open the program, or there should be a feature to save the current settings. Other settings seem to 'stick' such as custom fonts and appearance settings. 

Additional info:
Comment 1 Johan Cwiklinski 2008-08-09 03:57:32 EDT
I cannot reproduce your problem (on a x86_64 system at least), if I uncheck "keep window open when it loses focus", it's still unchecked when I run yakuake again.

Maybe you should try to delete (or move) your current yakuake settigs file (~/.kde/share/config/yakuakerc) and see if the problem persits.
Comment 2 Marek Mahut 2008-12-20 10:04:49 EST
Claude can you confirm?
Comment 3 Johan Cwiklinski 2008-12-23 02:03:02 EST
(In reply to comment #0)
> 3.Close yakuake and reopen it; the setting will be checked again

Are you sure that issue appears when you close yakuake ? 
Or does it when you logout from KDE, without closing yakuake before ?

I can only reproduce the error when I logout from KDE, but not when I close yakueke myself (see, bug #477736).
Comment 4 Johan Cwiklinski 2009-01-07 14:53:28 EST

*** This bug has been marked as a duplicate of bug 477736 ***
Comment 5 Claude Jones 2009-01-09 11:03:47 EST
(In reply to comment #3)
> (In reply to comment #0)
> > 3.Close yakuake and reopen it; the setting will be checked again
> 
> Are you sure that issue appears when you close yakuake ? 
> Or does it when you logout from KDE, without closing yakuake before ?
> 
> I can only reproduce the error when I logout from KDE, but not when I close
> yakueke myself (see, bug #477736).

OK - you hit the nail on the head. I have just confirmed that if I close Yakuake properly, the setting sticks. I have Yakuake set to auto-start when I log in to KDE, and I never closed it properly after going through the settings on this machine. I can only presume that I stumbled on the solution on previous machines without realizing it, so I was confounded when this happened on this one. Thanks for your help

Note You need to log in before you can comment on or make changes to this bug.