Bug 457656 - [fix available] icu causes OpenOffice.org to crash if the font Kartika.ttf is installed
[fix available] icu causes OpenOffice.org to crash if the font Kartika.ttf is...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: icu (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: Caolan McNamara
desktop-bugs@redhat.com
:
: 524573 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-02 20:02 EDT by Václav Mocek
Modified: 2011-01-13 18:49 EST (History)
5 users (show)

See Also:
Fixed In Version: icu-3.6-5.16
Doc Type: Bug Fix
Doc Text:
Due to a bug in the ICU library, when the "Kartika.ttf" font was installed, selecting "Format Cells" from the menu caused OpenOffice.org Calc to terminate unexpectedly. With this update, this error has been fixed, and the presence of "Kartika.ttf" no longer causes OpenOffice.org Calc to crash.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 18:49:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Automatically generated crash log. (9.06 KB, text/plain)
2008-08-02 20:02 EDT, Václav Mocek
no flags Details
My way of the installation of the font. (540 bytes, text/plain)
2008-08-02 20:04 EDT, Václav Mocek
no flags Details
The screenshot of last action before the crash. (67.18 KB, image/png)
2008-08-02 20:05 EDT, Václav Mocek
no flags Details
The screenshot - the basic information about the font. (89.30 KB, image/png)
2008-08-02 20:07 EDT, Václav Mocek
no flags Details
the patch to icu (593 bytes, patch)
2008-08-03 07:44 EDT, Caolan McNamara
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 83991 None None None Never

  None (edit)
Description Václav Mocek 2008-08-02 20:02:38 EDT
Created attachment 313263 [details]
Automatically generated crash log.

Description of problem:
If the Microsoft's font Kartika.ttf is installed and the menu item "Format Cells" is selected, the Open Office Calc always crashes.
The font Kartika is a standard part of Windows XP SP2. 
The problem was found on CentOS 5.2 and on Scientific Linux 5.2 and I deduce it is a problem of RHEL 5.2 as well.
Attachments provide more information.
 
Version-Release number of selected component (if applicable):
openoffice.org-calc-2.3.0-6.5.el5
openoffice.org-calc-2.3.0-6.5.1.el5_2

How reproducible:
Always.

Steps to Reproduce:
1. Install the font Kartika.ttf (my way is described in the attachment)
2. Run the Open Office Calc
3. Select some cell and run command "Format Cells" in the context menu (see the attachment)
  
Actual results:
The Open Office crashes and all documents have to be recovered more or less successfully.

Expected results:
No crash.

Additional info:
The font is described here: http://www.microsoft.com/typography/fonts/font.aspx?FID=281&FNAME=Kartika&FVER=1.06
Comment 1 Václav Mocek 2008-08-02 20:04:08 EDT
Created attachment 313264 [details]
My way of the installation of the font.
Comment 2 Václav Mocek 2008-08-02 20:05:22 EDT
Created attachment 313265 [details]
The screenshot of last action before the crash.
Comment 3 Václav Mocek 2008-08-02 20:07:00 EDT
Created attachment 313266 [details]
The screenshot - the basic information about the font.
Comment 4 Caolan McNamara 2008-08-03 07:38:12 EDT
Its actually a bug in icu
Comment 5 Caolan McNamara 2008-08-03 07:44:11 EDT
Created attachment 313290 [details]
the patch to icu
Comment 6 RHEL Product and Program Management 2008-08-03 07:49:34 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 7 RHEL Product and Program Management 2009-03-26 12:59:24 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 8 Caolan McNamara 2009-09-21 09:53:03 EDT
*** Bug 524573 has been marked as a duplicate of this bug. ***
Comment 16 Jaromir Hradilek 2011-01-10 07:21:04 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Due to a bug in the ICU library, when the "Kartika.ttf" font was installed, selecting "Format Cells" from the menu caused OpenOffice.org Calc to terminate unexpectedly. With this update, this error has been fixed, and the presence of "Kartika.ttf" no longer causes OpenOffice.org Calc to crash.
Comment 18 errata-xmlrpc 2011-01-13 18:49:53 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0127.html

Note You need to log in before you can comment on or make changes to this bug.