Bug 457675 - Long bug comments don't wrap in bugzilla 3.2 in show_bug.cgi/post_bug.cgi
Long bug comments don't wrap in bugzilla 3.2 in show_bug.cgi/post_bug.cgi
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-03 07:28 EDT by Noura El hawary
Modified: 2013-06-23 22:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-27 01:15:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noura El hawary 2008-08-03 07:28:16 EDT
in bugzilla 3.2 when adding a comment to a bug, the comment doesn't wrap if it is too long.

Noura
Comment 1 Max Kanat-Alexander 2008-09-03 19:53:19 EDT
Do you have a URL or any steps to reproduce for that?

It's definitely not a problem upstream.
Comment 2 David Lawrence 2008-11-24 15:51:17 EST
Ping Noura. Can you post a test case to reproduce this?
Comment 3 Noura El hawary 2008-11-27 00:35:31 EST
Hi Dave,

Basically in any bug like this one for example, type long word with no line breaks and it will not wrap when you commit like this:

testingggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggg


Is the above word wrapped in your screen?

Noura
Comment 4 David Lawrence 2008-11-27 01:08:18 EST
This is because the bug comment template is using Bugzilla::Util::wrap_comment which uses Text::Wrap. The default behaviour for Text::Wrap is to wrap on word boundaries such as spaces, newlines, tabs, etc. and also to wrap when the $columns value is reached which would have broken up the text properly. But
Bugzilla::Util::wrap_comment is overriding the default by setting $Text::Wrap::huge to 'overflow' which means it will not break up long words. 
So I am not sure we can fix this issue unless we add a Red Hat change to the function and set 'overflow' back to 'wrap'. This could cause problems with comments that are cut and pasted logs, dumps, traces, where the user may want
the original format of the text retained. I admit that it doesn't look very nice
but I vote we stay with the upstream on this one.

Dave
Comment 5 Noura El hawary 2008-11-27 01:15:04 EST
OKay I vote we stay with upstream as well, also no one really complained about it so i will close the bug.

Noura

Note You need to log in before you can comment on or make changes to this bug.