Bug 457684 - 8.63 was released
8.63 was released
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
http://www.ghostscript.com/awki/GPL_G...
:
Depends On:
Blocks: 435549
  Show dependency treegraph
 
Reported: 2008-08-03 09:52 EDT by acount closed by user
Modified: 2008-11-12 04:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-12 04:45:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description acount closed by user 2008-08-03 09:52:00 EDT
Approximately 238 bugs have been fixed since version 8.62. Of particular note are robustness and performance improvements with large files, invalid PDF, and font handling. The ghostpdl release features improved XPS to PDF conversion as well as a number of other bug fixes.

The major new feature of this release is multithreaded rendering. This can be requested by passing -dNumRenderingThreads=n on the command line. The input document is first parsed, and then each page is split into n bands which are rendered concurrently. This can provide a significant reduction in processing time on multi-core systems.

Images are now always interpolated in their source colorspace. This improves correctness for XPS documents and avoids bypassing the custom color management callbacks for interpolated images. Interpolation and color management are both expensive operations, so this affects performance with large images. The effect can be positive or negative depending on the file and the target resolution. If performance is a problem, we suggest running with -dNOINTERPOLATION.

Support for OpenPrinting Vector devices has been upgraded to version 1.0.

There are two new devices in this release, both experimental. Behdad Esfahbod has contributed a cairo output device which uses the cairo graphics library to generate PDF, SVG, EPS, or PNG files, based on the requested filename extension. The svgwrite device directly outputs Scalable Vector Graphics, the W3C XML vector graphics format. Both support only vector art at this point; text and images will not be represented efficiently.

=Incompatible changes=

The maximum number of color components has been reduced to 8 (from 252) as a performance improvement. Eight is the largest number commonly used and the largest number for which we support continuous tone images. Users with special needs can restore the previous behavior by setting the GS_CLIENT_COLOR_MAX_COMPONENTS preprocessor symbol to the required number of components at compile time.

The -Z: debugging option now uses 'realtime' instead of 'usertime' when reporting timing information on unix-like systems. This has always been the case on windows-like systems.

Obsolete makefiles for the DesqView environment have been removed.
Comment 1 Jon Stanley 2008-08-03 15:07:26 EDT
triaged
Comment 2 Fedora Update System 2008-08-04 12:16:15 EDT
ghostscript-8.63-1.fc9 has been submitted as an update for Fedora 9
Comment 3 Fedora Update System 2008-08-07 19:52:05 EDT
ghostscript-8.63-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ghostscript'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7035
Comment 4 acount closed by user 2008-09-14 13:12:41 EDT
is it ready for Fedora 9 *updates* ?
Comment 5 acount closed by user 2008-09-20 19:12:58 EDT
ghostscript-fonts and urw-fonts packages can be deleted because they are the *same* , and they are already included into ghostscript since 8.62 version(in Resource/Font/ directory)


-thanks-
Comment 6 Fedora Update System 2008-09-24 20:06:34 EDT
ghostscript-8.63-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Tim Waugh 2008-09-25 04:54:20 EDT
Reopening to investigate comment #5.
Comment 8 acount closed by user 2008-09-25 09:39:37 EDT
(In reply to comment #5)

> ghostscript-fonts and urw-fonts packages can be deleted because they are the
> *same* , and they are already included into ghostscript since 8.62 version(in
> Resource/Font/ directory)

here they are: http://svn.ghostscript.com/ghostscript/trunk/gs/Resource/Font/
Comment 9 acount closed by user 2008-09-25 09:43:30 EDT
(In reply to comment #8)
> (In reply to comment #5)
> 
> > ghostscript-fonts and urw-fonts packages can be deleted because they are the
> > *same* , and they are already included into ghostscript since 8.62 version(in
> > Resource/Font/ directory)
> 
> here they are: http://svn.ghostscript.com/ghostscript/trunk/gs/Resource/Font/

And *.afm *.pfb *.pfm 'sources', aka urw-fonts package, here: http://svn.ghostscript.com/ghostscript/trunk/urw-fonts/
Comment 10 acount closed by user 2008-11-12 04:45:16 EST
(In reply to comment #7)
> Reopening to investigate comment #5.

bug #435549

Note You need to log in before you can comment on or make changes to this bug.