Bug 457701 - Can't install RPM packages from desktop
Can't install RPM packages from desktop
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-03 22:06 EDT by Alan Ott
Modified: 2008-08-05 08:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-05 08:54:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Ott 2008-08-03 22:06:37 EDT
Description of problem:
When double-clicking an RPM package on the desktop, a message popup appears which says:

"Failed to Install
You don't have the necessary
privileges to install local packages"

Version-Release number of selected component (if applicable):

Fedora 9

How reproducible:
Very

Steps to Reproduce:
1. Running as root, put an RPM on the desktop
2. Double click it
3.
  
Actual results:
Error message described above appears.

Expected results:
I would expect the package to be installed.


Additional info:

I used the VirtualBox RPM for FC9 available from virtualbox.org:
     VirtualBox-1.6.4_33808_fedora9-1.i586.rpm
Comment 1 Ray Strode [halfline] 2008-08-04 09:46:51 EDT
moving to packagekit.

if you run polkit-gnome-authorization and explicitly give root the authorization to install packages does it work then?
Comment 2 Richard Hughes 2008-08-05 08:54:51 EDT
Don't run your desktop as root. Please see http://fedoraproject.org/wiki/PackageKitFaq -- thanks.

Note You need to log in before you can comment on or make changes to this bug.