This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 457804 - Flag notification emails are missing data fields
Flag notification emails are missing data fields
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
All Linux
high Severity medium (vote)
: ---
: ---
Assigned To: Noura El hawary
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-04 14:33 EDT by Suzanne Yeghiayan
Modified: 2013-06-24 00:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-06 12:28:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
v1 to add more info to flag notification emails (855 bytes, patch)
2008-08-06 12:07 EDT, Noura El hawary
dkl: review+
Details | Diff

  None (edit)
Description Suzanne Yeghiayan 2008-08-04 14:33:45 EDT
Description of problem:

Bugzilla 3.0 sent flag notification email that looked like this:

****************************************************************
Bug 456866: Backport pmutils 1.1 to RHEL 5.3
Product: Red Hat Enterprise Linux 5
Version: 5.2
Component: pm-utils

David Mair <dmair@redhat.com> has asked  for exception:
https://bugzilla.redhat.com/show_bug.cgi?id=456866

------- Additional Comments from David Mair <dmair@redhat.com>
Fixed the flags so this is an exception for *5.3*. 
****************************************************************

Bugzilla 3.2 now sends flag notification email that looks like this:

****************************************************************
RHEL Product and Program Management <pm-rhel@redhat.com> has granted Daniel
Riek <riek@redhat.com>'s request for exception:
Bug 439491: LTC:5.3:201310:Integrate spu-tools as new package into RHEL5.3
https://bugzilla.redhat.com/show_bug.cgi?id=439491 
****************************************************************
Version-Release number of selected component (if applicable):

Bugzilla 3.2

How reproducible:

Just view any flag notification email from bugzilla 3.2 (since upgrade).

Steps to Reproduce:
1.
2.
3.
  
Actual results:

See above.

Expected results:

Please restore flag notification email to contain the following information:

Bug: 
Product: 
Version: 
Component: 

who made flag change ...

last Comment ...


Additional info:

This info is needed by Program Management to be able to quickly review flag notification.
Comment 1 Noura El hawary 2008-08-06 12:07:20 EDT
Created attachment 313592 [details]
v1 to add more info to flag notification emails

added product, component , version to the flag notification email.

Noura
Comment 2 David Lawrence 2008-08-06 12:16:29 EDT
Comment on attachment 313592 [details]
v1 to add more info to flag notification emails

>Index: template/en/default/request/email.txt.tmpl
>===================================================================
>RCS file: /cvs/qa/rh_bugzilla_3/template/en/default/request/email.txt.tmpl,v
>retrieving revision 1.1.1.1
>diff -p -u -r1.1.1.1 email.txt.tmpl
>--- template/en/default/request/email.txt.tmpl	19 Nov 2007 22:11:21 -0000	1.1.1.1
>+++ template/en/default/request/email.txt.tmpl	6 Aug 2008 15:38:14 -0000
>@@ -53,6 +53,13 @@ X-Bugzilla-Type: request
> [%+ USE wrap -%]
> [%- FILTER bullet = wrap(80) -%]
> 
>+[%# REDHAT EXTENSION START 457804 %]
>+Product: [% bug.product FILTER html %]
>+Version: [% bug.version FILTER html %]
>+Component: [% bug.component FILTER html %]
>+[%# REDHAT EXTENSION END 457804 %]
>+
>+

Nit: Remove the extra empty line above. Otherwise looks great and works well as revealed in mailer.testfile.

> [% IF on_behalf_of %]
> [% user.identity %] has reassigned [% flag.setter.identity %]'s request for [% flag.type.name %]
> [% to_identity %]:
Comment 3 Noura El hawary 2008-08-06 12:28:31 EDT
Thanks for the review Dave, removed line and committed to cvs should be live in the next package push, coming soon.

Noura

Note You need to log in before you can comment on or make changes to this bug.