Bug 457871 - figure out whats up with kdetheme patch
figure out whats up with kdetheme patch
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-desktop (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-05 00:58 EDT by Matthias Clasen
Modified: 2008-08-05 17:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-05 17:23:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2008-08-05 00:58:46 EDT
gnome-desktop-2.1.90-kdetheme.patch

This is ancient, and I have no idea if it still makes any sense.
Might need some input from the kde side.
Comment 1 Paul W. Frields 2008-08-05 07:29:43 EDT
Just doing some bug triage early this morning to help out... I'm assuming since this is from one Desktop guy to another, Ray knows what this is about. ;-)
Comment 2 Ray Strode [halfline] 2008-08-05 10:10:42 EDT
should be fixed in the next build (not bothering pushing a build out yet though)
Comment 3 Ray Strode [halfline] 2008-08-05 10:15:40 EDT
reopening... I closed the wrong bug report (too many browser windows open).
Comment 4 Rex Dieter 2008-08-05 10:19:53 EDT
A little background, what's the purpose of the kdetheme patch?
Comment 5 Ngo Than 2008-08-05 11:06:25 EDT
the oxygen icon theme is the default for KDE-4 that we have in F-9/Rawhide.
it doesn't make sense to use crystalsvg for rawhide.
Comment 6 Matthias Clasen 2008-08-05 17:16:20 EDT
> A little background, what's the purpose of the kdetheme patch?

The patch is so old, it is hard to tell. But from looking at the surrounding code, there are several layers of fallback code for locating icons, and one
of the last layers manually scrounges through a bunch of semi-random icon theme directories. This is one for the bit-bucket, I guess.

Note You need to log in before you can comment on or make changes to this bug.