This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 457894 - logrotate definition for bacula logs is incorrect
logrotate definition for bacula logs is incorrect
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: bacula (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-05 05:23 EDT by Christian Nolte
Modified: 2008-09-16 19:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-16 19:22:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christian Nolte 2008-08-05 05:23:38 EDT
/etc/logrotate.d/bacula does not work correctly if one uses the default configuration, because in bacula-dir.conf:

append = "/var/log/bacula.log" = all, !skipped

and in /etc/logrotate.d/bacula:

# Bacula logrotate script

/var/log/bacula/*.log {
    monthly
    rotate 4
    notifempty
    missingok
}

the logfile paths do not match. Furthermore the warning in bacula-dir in the Messages resource:

#
# WARNING! the following will create a file that you must cycle from
#          time to time as it will grow indefinitely. However, it will
#          also keep all your messages if they scroll off the console.
#
  append = "/var/spool/bacula/log" = all, !skipped

would be obsolete, if logrotate also would rotate the /var/spool/bacula/log on a monthly basis.

The logrotate definition should be changed to:

/var/log/bacula/*.log /var/spool/bacula/log {
    monthly
    rotate 4
    notifempty
    missingok
}
Comment 1 Jon Ciesla 2008-08-29 13:27:11 EDT
Fixed in CVS for devel, 9 and 8 (no spec changes yet).  Andreas, should I push a build, or are you close to a fix for BZ 458432?
Comment 2 Fedora Update System 2008-09-10 12:13:58 EDT
bacula-2.2.8-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/bacula-2.2.8-3.fc9
Comment 3 Fedora Update System 2008-09-11 13:02:03 EDT
bacula-2.2.8-3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bacula'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7857
Comment 4 Fedora Update System 2008-09-16 19:22:14 EDT
bacula-2.2.8-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.