Bug 457910 - memberOf: Make the filter of the treated entries configurable
memberOf: Make the filter of the treated entries configurable
Status: CLOSED WONTFIX
Product: 389
Classification: Community
Component: Server - memberOf Plug-in (Show other bugs)
1.1.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Nathan Kinder
Chandrasekar Kannan
:
Depends On:
Blocks: 434915
  Show dependency treegraph
 
Reported: 2008-08-05 07:18 EDT by Andrey Ivanov
Modified: 2015-01-04 18:33 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-12 16:08:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrey Ivanov 2008-08-05 07:18:44 EDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

In the latest version of memberof.c (1.13 in CVS) starting form the line 2013 :
if ((filter = fetch_attr(e, "filter", "(objectclass=inetuser)")) == NULL)
        {
                *returncode = LDAP_OBJECT_CLASS_VIOLATION;
                rv = SLAPI_DSE_CALLBACK_ERROR;
                goto out;
        }

It means that the filter used to determine the subset of entries treated by the memberOf plugin is hardcoded to "(objectclass=inetuser)"


Reproducible: Always

Steps to Reproduce:
1. Look at the code of memberof.c staring from the line 2013

Actual Results:  
The filter is hardcoded to "(objectclass=inetuser)"

Expected Results:  
The filter should be configurable like it is already the case for the parameters memberOfGroupAttr and memberOfAttr.

It is not a bug, it is a feature request.
Comment 1 Nathan Kinder 2009-01-12 13:54:36 EST
The hardcoded filter is simply a default filter for the memberOf fix-up task.  The task filter can be specified in the task entry that is created as the "filter" attribute, which is the recommended thing to do when creating the fix-up task.  The fixup-memberof.pl utility that creates the fixup task entry has a "-f" option for specifying this filter.

We could add another configuration setting that allows you to configure the default task filter if one is not specified in the task, but I don't see a lot of value in doing so.  I also do not want to make this configuration setting required, so we would still need a hardcoded default.
Comment 2 Andrey Ivanov 2009-01-12 15:56:40 EST
If it's only the default filter for the memberOf fix-up task, you are right. There is no need to create another configuration parameter. I thought (or maybe it was the case in one of the previous code versions) that there was a limitation on the "real time" updates of the entries. After looking through the latest version of the code the filter is indeed used exclusively in the fix-up task.
Comment 3 Nathan Kinder 2009-01-12 16:08:58 EST
Thanks for your input, Andrey.  Since you agree with my assessment, I'm going to close this bug.

Note You need to log in before you can comment on or make changes to this bug.