Bug 457922 - nvidia ethernet cards may require some configuration whenused with mrg messaging
nvidia ethernet cards may require some configuration whenused with mrg messaging
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Release_Notes (Show other bugs)
1.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lana Brindley
Kim van der Riet
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-05 09:50 EDT by Gordon Sim
Modified: 2013-10-23 19:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-07 22:34:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Sim 2008-08-05 09:50:17 EDT
The symptom is that performance tests over loopback are drastically faster than the same test over the ethernet connection though the bandwidth is _not_ the bottleneck.

If the following warnings are seen in the dmesg output then the default configuration should be changed:

"eth0: too many iterations (6) in nv_nic_irq."

The change required is to add a line such as:
 
   options forcedeth max_interrupt_work=30 

to /etc/modprobe.conf.

See also https://bugzilla.redhat.com/show_bug.cgi?id=179422
Comment 1 Lana Brindley 2008-08-05 23:34:26 EDT
After conversation with cctrieloff on IRC:
* Formal release notes will not be issued for 1.0.1
* This information will be made available on the Wiki.

LKB
Comment 2 Carl Trieloff 2008-08-06 11:28:12 EDT
To complete the comment, this will be included in a tuning section in the 1.1 user guide for msg.
Comment 3 Carl Trieloff 2008-08-06 11:28:53 EDT
I will add note to wiki for 1.0.1
Comment 4 Lana Brindley 2008-08-07 21:52:11 EDT
Thanks Carl,

LKB
Comment 5 Lana Brindley 2008-10-29 18:03:22 EDT
Due to be written Mon 3 Nov and will be available for technical review ~ 5 Nov

LKB
Comment 6 Lana Brindley 2008-11-03 23:42:28 EST
This document is now available for tech review.

LKB
Comment 7 Lana Brindley 2008-11-13 02:40:21 EST
It has now been removed from the afore-said document. If this is required to go into release notes for 1.1, can you please change the component to Release_Notes?

Thanks,
LKB
Comment 8 Gordon Sim 2008-12-02 03:42:58 EST
Component is 'Release_Notes'; is any other information requireed? I imagine we canuse the exact same wording as for the last release.
Comment 9 Lana Brindley 2008-12-07 22:34:47 EST
Thanks Gordon.

<row>
	<entry>
		457922
	</entry>
	<entry>
		<para>
			Performance tests occurring over a loopback connection are much faster than when run over an ethernet connection, where limited bandwidth is not the cause. The error given is 
<screen>
eth0: too many iterations (6) in nv_nic_irq.
</screen>
			Open <filename>/etc.modprobe.conf</filename> and add the following line: 
<programlisting>
options forcedeth max_interrupt_work=30
</programlisting>
		</para>
	</entry>
</row>

LKB

Note You need to log in before you can comment on or make changes to this bug.