Bug 458033 - No hardware cursor on F10-Alpha
No hardware cursor on F10-Alpha
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
:
: 470841 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-06 04:36 EDT by Kazutoshi Morioka
Modified: 2009-03-03 03:46 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-28 18:42:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log from Fedora 9 (41.43 KB, text/plain)
2008-08-06 10:38 EDT, Kazutoshi Morioka
no flags Details
/etc/X11/xorg.conf from Fedora 9 (598 bytes, text/plain)
2008-08-06 10:39 EDT, Kazutoshi Morioka
no flags Details
/var/log/Xorg.0.log from Fedora 10 Alpha with SWCursor (49.31 KB, text/plain)
2008-08-06 10:41 EDT, Kazutoshi Morioka
no flags Details
/var/log/Xorg.0.log from Fedora 10 (52.12 KB, text/plain)
2008-08-06 10:43 EDT, Kazutoshi Morioka
no flags Details
/var/log/Xorg.0.log of xorg-x11-drv-openchrome-0.2.902-10.fc10.x86_64 (13.92 KB, text/plain)
2008-08-06 22:44 EDT, Kazutoshi Morioka
no flags Details

  None (edit)
Description Kazutoshi Morioka 2008-08-06 04:36:34 EDT
Description of problem:
No cursor was displayed on the screen of F10-Alpha.
I created /etc/X11/xorg.conf with contains lines below, and got a cursor.

Section "Device"
	Identifier  "Videocard0"
	Driver      "openchrome"
	Option      "SWCursor" "on"
EndSection

Version-Release number of selected component (if applicable):
xorg-x11-drv-openchrome-0.2.902-8.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Install F10-Alpha
2.Boot it
3.See login screen
  
Actual results:
No cursor was displayed.

Expected results:
Mouse corsor will be displayed.

Additional info:
My smolt id is pub_16745373-5bc6-4af3-83cd-569f3228f5a3
Comment 1 Xavier Bachelot 2008-08-06 05:53:27 EDT
Was the hardware cursor working properly with either F8 or F9 ?
Comment 2 Kazutoshi Morioka 2008-08-06 10:38:33 EDT
Created attachment 313574 [details]
/var/log/Xorg.0.log from Fedora 9
Comment 3 Kazutoshi Morioka 2008-08-06 10:39:11 EDT
Created attachment 313575 [details]
/etc/X11/xorg.conf from Fedora 9
Comment 4 Kazutoshi Morioka 2008-08-06 10:41:59 EDT
Created attachment 313578 [details]
/var/log/Xorg.0.log from Fedora 10 Alpha with SWCursor
Comment 5 Kazutoshi Morioka 2008-08-06 10:43:32 EDT
Created attachment 313579 [details]
/var/log/Xorg.0.log from Fedora 10
Comment 6 Kazutoshi Morioka 2008-08-06 10:44:46 EDT
(In reply to comment #1)
> Was the hardware cursor working properly with either F8 or F9 ?

Yes, I think so.
Attached logs and xorg.conf.
Comment 7 Xavier Bachelot 2008-08-06 16:39:38 EDT
please try latest rawhide build (0.2.902-10.fc10):
http://koji.fedoraproject.org/koji/taskinfo?taskID=763719
Comment 8 Kazutoshi Morioka 2008-08-06 22:08:12 EDT
(In reply to comment #7)
> please try latest rawhide build (0.2.902-10.fc10):
> http://koji.fedoraproject.org/koji/taskinfo?taskID=763719

This works fine. Thank you!
Comment 9 Kazutoshi Morioka 2008-08-06 22:44:13 EDT
Created attachment 313660 [details]
/var/log/Xorg.0.log of xorg-x11-drv-openchrome-0.2.902-10.fc10.x86_64

Although it seems working fine, I got this backtrace:

(==) CHROME(0): Depth 24, (==) framebuffer bpp 32
(==) CHROME(0): RGB weight 888
(==) CHROME(0): Default visual is TrueColor
(--) CHROME(0): Chipset: K8M800/K8N800
(--) CHROME(0): Chipset revision: 0

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x65) [0x479c05]
1: /lib64/libc.so.6 [0x1a31130]
2: /usr/lib64/libpciaccess.so.0 [0x7db863]
3: /usr/lib64/libpciaccess.so.0 [0x7db9c0]
4: /usr/lib64/libpciaccess.so.0(pci_device_cfg_read+0x2d) [0x7da55d]
5: /usr/lib64/libpciaccess.so.0(pci_device_cfg_read_u8+0x13) [0x7da593]
6: /usr/lib64/xorg/modules/drivers//openchrome_drv.so [0x7fea6c5ff5c6]
7: /usr/bin/Xorg(InitOutput+0x969) [0x463079]
8: /usr/bin/Xorg(main+0x286) [0x42c9d6]
9: /lib64/libc.so.6(__libc_start_main+0xe6) [0x1a1c566]
10: /usr/bin/Xorg(FontFileCompleteXLFD+0x279) [0x42bf89]

Fatal server error:
Caught signal 11.  Server aborting
Comment 10 Kazutoshi Morioka 2008-08-06 22:54:22 EDT
And old bugs are return.
Vertical green lines after VT switching.
Black screen after Ctrl+Alt+Delete to abort X server.
Comment 11 Kazutoshi Morioka 2008-08-06 23:10:24 EDT
(In reply to comment #10)
> And old bugs are return.
> Vertical green lines after VT switching.
> Black screen after Ctrl+Alt+Delete to abort X server.

These bugs are introduced since 0.2.902-9.fc10.
No green vertical lines are shown with 0.2.902-8.fc10.
Comment 12 Xavier Bachelot 2008-08-07 05:54:26 EDT
so, is the hardware cursor issue fixed or not ? Can the backtrace be triggered all the time or not ? The code that probe the video ram amount has not been modified, so this is a bit strange. Also the VT switch issues are known, but this probably belongs to another bug report.
Comment 13 Kazutoshi Morioka 2008-08-07 11:24:27 EDT
(In reply to comment #12)
> so, is the hardware cursor issue fixed or not ? Can the backtrace be triggered
> all the time or not ? The code that probe the video ram amount has not been
> modified, so this is a bit strange. Also the VT switch issues are known, but
> this probably belongs to another bug report.

0.2.902-10.fc10 fixed hardware cursor issue.
Backtrace was triggered occasionally, not every time.
I saw backtraces two times, but I can not reproduce it.
Comment 14 Xavier Bachelot 2008-08-28 18:42:10 EDT
Hardware cursor is working again, so I close this bug. Please open new bugs for the other issues if you're still affected.

Thanks and regards,
Xavier
Comment 15 Xavier Bachelot 2009-03-03 03:46:15 EST
*** Bug 470841 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.