Bug 458040 - URL on text-mode network install checked too late
URL on text-mode network install checked too late
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-06 05:31 EDT by Javier Palacios
Modified: 2008-08-07 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-06 10:36:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Javier Palacios 2008-08-06 05:31:45 EDT
I'm performing a text mode install with the netboot iso. If I type a bad URL, the installer does not complain, but takes later stages from the CD. But later on, after modifying partition table and format required partitions, it complains about the URL when tries to download metadata from the repository.
That might leave a system unusable, so disallowing internet search for a right mirror path, but the worst comes after discovering that the URL can only be modified on graphical mode.

This happens with the netboot iso for F9 downloaded a couple of days ago, but I'm not able to tell if happens also on previous versions, as I'm quite used to perform kickstart install.
Comment 1 Chris Lumens 2008-08-06 10:36:37 EDT
The graphical installer is better in this regard in that there is a repo editor that will allow you to modify your installation source should there be a problem like what you are describing.  However, one of the limitations of text mode is that these sorts of things will simply not be added based on the available screen real estate and amount of other work needing to be done.  I strongly urge you to either do a graphical install or a VNC install.

If you are just using the kernel and the initrd instead of the boot.iso under Rawhide, this will be slightly better in that the URL provided will have to be used to fetch the stage2 image, at which time typos will be caught.
Comment 2 Javier Palacios 2008-08-07 02:53:57 EDT
In my opinion this one is an important bug. If the text installer is so much unsupported as mark it as WONTFIX, i strongly belived that it should be just have been dropped on whole Fedora, or at least from the install menu on the netboot image.
At least you will not get more reports about things that fail on text mode, because as I understand from the other bugs that I did open after this one, many other text interfaces are actually unsupported
Comment 3 Andy Lindeberg 2008-08-07 09:07:08 EDT
The option to select text mode was indeed removed from the splash screen in rawhide (I can find the date it was taken out, if you'd like), and this will be incorporated into F10.
Comment 4 Javier Palacios 2008-08-07 12:54:13 EDT
(In reply to comment #3)
> The option to select text mode was indeed removed from the splash screen in
> rawhide (I can find the date it was taken out, if you'd like), and this will be
> incorporated into F10.

So (and this is only an opinion) blocking bugs related to not yet dropped text mode on F9 should be fixed or at least investigated a little bit.

Note You need to log in before you can comment on or make changes to this bug.