Bug 458060 - bugzilla.runQuery doesn't seem to work
bugzilla.runQuery doesn't seem to work
Status: CLOSED NOTABUG
Product: Bugzilla
Classification: Community
Component: WebService (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: Noura El hawary
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-06 09:10 EDT by Michał Bentkowski
Modified: 2008-08-07 23:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-07 23:18:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michał Bentkowski 2008-08-06 09:10:29 EDT
Description of problem:
bugzilla.runQuery doesn't seem to work

How reproducible:
Always

Steps to Reproduce:
Run python and type:
x=xmlrpclib.ServerProxy("https://bugzilla.redhat.com/xmlrpc.cgi")
x.bugzilla.runQuery({"emailreporter2": 1, "email2": "fevapp@o2.pl", "bug_status": ["NEW", "ASSIGNED", "CLOSED"]})

Actual results:
Waiting forever...

Expected results:
Return output
Comment 1 Noura El hawary 2008-08-07 23:18:05 EDT
(In reply to comment #0)
> Description of problem:
> bugzilla.runQuery doesn't seem to work
> 
> How reproducible:
> Always
> 
> Steps to Reproduce:
> Run python and type:
> x=xmlrpclib.ServerProxy("https://bugzilla.redhat.com/xmlrpc.cgi")
> x.bugzilla.runQuery({"emailreporter2": 1, "email2": "fevapp@o2.pl",
> "bug_status": ["NEW", "ASSIGNED", "CLOSED"]})
> 

HI ,,

You search criteria is missing one param which is :
emailtype2 : 'exact'

I tried it with that param and it works fine for me.

so your should be as the following:

x=xmlrpclib.ServerProxy("https://bugzilla.redhat.com/xmlrpc.cgi")
x.bugzilla.runQuery({"emailreporter2": 1, "email2": "fevapp@o2.pl",
"bug_status": ["NEW", "ASSIGNED", "CLOSED"], "emailtype2": "exact"})
 
Noura


> Actual results:
> Waiting forever...
> 
> Expected results:
> Return output

Note You need to log in before you can comment on or make changes to this bug.