Bug 458112 - kde4: apps keeps run in sudo env after konsole :(
kde4: apps keeps run in sudo env after konsole :(
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-06 10:32 EDT by Anton Arapov
Modified: 2014-06-18 04:02 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-26 11:26:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 143880 None None None Never

  None (edit)
Description Anton Arapov 2008-08-06 10:32:47 EDT
Description of problem:
%subj%

Version-Release number of selected component (if applicable):
kdebase-4.0.5-5.fc9.x86_64

How reproducible:
every time

Steps to Reproduce:
1. $ konsole
2. $ sudo -i
3. # top
4. *close* konsole by using X at top right
  
Actual results:
$ ps xua | grep top
you'll see top running

Expected results:
killed top, or whatsoever was ran in sudo
Comment 1 Rex Dieter 2008-08-06 10:37:59 EDT
doubt there's anything to do to fix that.  ??

See, top is now running as root, and your user permissions aren't enough to terminate it anymore.
Comment 2 Rex Dieter 2008-08-06 10:39:12 EDT
It *may* be possible, but only if sudo can act as a proxy to forward signals (which I doubt)
Comment 3 Anton Arapov 2008-08-06 10:41:10 EDT
I believe it is odd behaviour ... everything must be killed inside.

can you reproduce the problem?
Comment 4 Rex Dieter 2008-08-06 10:50:53 EDT
I can reproduce it alright, I'm just saying what you want/expect may not be possible.
Comment 5 Kevin Kofler 2008-08-06 11:07:27 EDT
Indeed. And in any case, this is not a bug in Konsole, in fact it has nothing to do with Konsole at all.
Comment 6 Anton Arapov 2008-08-06 13:09:31 EDT
(In reply to comment #4)
Okay,... Why does this work as I'm expecting in gnome-terminal then?
Comment 7 Rex Dieter 2008-08-06 13:13:40 EDT
gnome-terminal does the same as konsole for me. I see top processes (owned by root) still running after close.
Comment 8 Anton Arapov 2008-08-07 04:23:33 EDT
I would like to close kernel issues in the same way... >:)

It _is_ the problem, not the problem of konsole, may be but the problem of kde, may be kwin, I do not know... I just tried to see what the KDE4 _is_... 

Just try to do the same in gnome environment in any terminal(not sure about konsole). It kills everything inside the terminal, no matter in sudo or not.

It works just fine in WMII as well. The only WM/DE so far that did not kill apps inside sudo is KWIN/KDE.

I want it fixed from the moment when the report was marked as NOTABUG! =)
Comment 9 Rex Dieter 2008-08-07 08:18:48 EDT
To be clear and re-iterate.  I can't reproduce this.  gnome-terminal for me does the same thing as konsole.
Comment 10 Anton Arapov 2008-08-07 08:34:46 EDT
Did you try to reproduce it in another WM/DE ?
Comment 11 Anton Arapov 2008-08-08 04:46:55 EDT
had a chance to test in kde3. works fine == everything was killed inside the terminal.
Comment 12 Steven M. Parrish 2008-08-26 11:26:06 EDT
We found that this bug has been already registered in the upstream database (https://bugs.kde.org/show_bug.cgi?id=143880) and believe that it is more appropriate to let it be resolved upstream.

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.