Bug 458117 - Show Dependency Tree incorrectly reports "does not block any bugs" if not logged in
Show Dependency Tree incorrectly reports "does not block any bugs" if not log...
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: Dependency Views (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: Noura El hawary
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-06 11:04 EDT by Gary Smith
Modified: 2013-06-24 00:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-08 01:17:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
v1 modify dep tree error (1.10 KB, patch)
2008-08-08 00:59 EDT, Noura El hawary
dkl: review+
Details | Diff

  None (edit)
Description Gary Smith 2008-08-06 11:04:03 EDT
Description of problem:
Whilst not logged into Bugzilla, a BZ page is displayed without
requesting login. Clicking on the dependency tree link does not request
login, but displays incorrect information about dependencies because we
are not logged in.

Version-Release number of selected component (if applicable):
n/a

How reproducible:
Easily, see steps below.

Steps to Reproduce:

1) From IT#173494, whilst not logged into Bugzilla, click on the link
for Bugzilla 441694.

2) This opens up the BZ, without asking for BZ login.

3) Clicking on "Show Dependency Tree", opens up a page saying "Bug
441694 does not block any bugs".

4) Click BACK to return to BZ.

5) Click on "Blocks: 391511". This opens up a page saying "You are not
authorized to access bug #391511. To see this bug, you must first log in
to an account with the appropriate permissions."

6) Click on the "log in to an account" link , and logging in on the next
page then displays the Tracker BZ as expected.

7) Click BACK x 3 to the original BZ, and click on "Show Dependency
Tree".

8) This page now correctly shows that "Bug 441694 blocks one open bug".

  
Actual results:
Clicking on "Show Dependency Tree", opens up a page saying "Bug
441694 does not block any bugs" when it definitely does.

Expected results:
In the first instance, BZ should ask me to login. When generating the dependency tree info, it should ask me to login if needed. It should not display incorrect misleading statements because I am not logged in, ie "does not block any bugs"


Additional info:
Date and Time: Wednesday August 6th @ 09:00 BST

At the moment, it is not obvious that you're not logged in, it simply offers a very small "Log In" on the top bar. Perhaps make it more obvious that the user is NOT logged in, ie a large font message in different colour.
Comment 1 Noura El hawary 2008-08-08 00:59:16 EDT
Created attachment 313780 [details]
v1 modify dep tree error 

Thanks for reporting this issue , we are going to modify the error to give more information to the user.

Noura
Comment 2 David Lawrence 2008-08-08 01:03:13 EDT
Comment on attachment 313780 [details]
v1 modify dep tree error 

Looks good.
Comment 3 Noura El hawary 2008-08-08 01:17:22 EDT
Thanks for the review Dave, Committed to cvs.

Noura

Note You need to log in before you can comment on or make changes to this bug.