Bug 458126 - Easier branding for deployed satellites
Easier branding for deployed satellites
Status: CLOSED WONTFIX
Product: Red Hat Satellite 5
Classification: Red Hat
Component: New Feature (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Todd Sanders
Brandon Perkins
aide
:
Depends On: 131019
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-06 11:49 EDT by Matt Domsch
Modified: 2008-10-29 10:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-29 10:22:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2008-08-06 11:49:06 EDT
Moving to the right Product.  Very likely this code is useless now, it's been 4 years since being filed...

+++ This bug was initially created as a clone of Bug #131019 +++

Description of problem:

As a satellite server owner, I'd like to have my company's branding 
somehow on the pages.  Otherwise, it's hard to tell at a glance if 
I'm looking at my satellite server or at Red Hat's server in the 
browser.

Simple branding ideas:
1) Config option for setting HTML page titles.  The title of all HTML 
pages starts with "Red Hat Network".  I'd prefer to set it to "Red 
Hat Network Satellite @ Dell" for example.  This can be done by 
editing /usr/lib/perl5/site_perl/5.6.1/i386-linux/Sniglets/Navi.pm 
and changing the title.  It would be nice if the title were a config 
option in /etc/rhn/rhn.conf  or similar.

2) Adding the company logo.  I've added my company's logo to the top 
of the page by modifying these two files as noted.  Again, a config 
option would be really nice to have, where if set would put the 
appropriate logo and alt text in place.

--- nav/styles/navbar_bottom.txt.~2~    Wed Aug 25 17:43:14 2004
+++ nav/styles/navbar_bottom.txt        Wed Aug 25 17:47:37 2004
@@ -1,4 +1,5 @@
 </span>
+    <img id="delllogo" src="/img/dell_logo.gif" alt="Dell">
      <a href="/help/"><img id="navhelp" src="/img/rhn-header_icon-
help.gif" alt="Help" /></a>

 <table border="0" cellpadding="0" cellspacing="0" width="100%">
--- css/rhn.css.~1~     Mon Apr  5 14:35:08 2004
+++ css/rhn.css Wed Aug 25 17:48:04 2004
@@ -850,6 +850,13 @@
   color: black;
 }

+#delllogo {
+  border: 0;
+  position: absolute;
+  top: 5px;
+  left: 400px;
+}
+
 #navlogo {
   border: 0;
   margin: 4px 13px;

--- Additional comment from dmcgrath@redhat.com on 2005-01-28 17:33:05 EDT ---

This is a feature request, not a bug.
It needs to be prioritized with other incoming RHN feature requests.
Comment 1 Matt Domsch 2008-10-29 10:22:04 EDT
These have been open for years with no investigation or resolution.  Since then the code base has moved on significantly, such that many of these no longer would apply to the current spacewalk code.  I'm closing these requests in the hope they're no longer necessary, or if they are, they'll get discovered anew.

Note You need to log in before you can comment on or make changes to this bug.