Bug 458143 - usermod relabeling old home dir on change
usermod relabeling old home dir on change
Status: CLOSED DUPLICATE of bug 494575
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: shadow-utils (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Peter Vrabec
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-06 13:16 EDT by Jason Bradley Nance
Modified: 2012-12-03 07:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-24 16:41:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Bradley Nance 2008-08-06 13:16:20 EDT
Description of problem:
When changing a user's home directory using 'usermod', it seems to be calling 'restorecon -R' on the old home directory.  This causes issues when the old home directory doesn't exist for some reason - especially if done during a kickstart.


Version-Release number of selected component (if applicable):
4.0.17-13.el5

How reproducible:
Always.

Steps to Reproduce:
1. usermod -d / ident  (ident's home dir is set to /home/ident by default, which doesn't exist)
2. 
3.
  
Actual results:
/sbin/restorecon:  error while labeling files under /home/ident
usermod: warning: unable to relabel the homedir /home/ident for ident.

Expected results:


Additional info:
Comment 1 Subhendu Ghosh 2009-10-24 16:41:36 EDT

*** This bug has been marked as a duplicate of bug 494575 ***

Note You need to log in before you can comment on or make changes to this bug.