Bug 458218 - emacs blocking logout
emacs blocking logout
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Novotny
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-06 22:03 EDT by Jonathan Kamens
Modified: 2009-09-21 07:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-21 07:41:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2008-08-06 22:03:42 EDT
With current rawhide, including gnome-session-2.23.6-1.fc10 and emacs-22.2-5.fc9, if I launch emacs and then try to log out, I get this:

A program is still running:
Emacs Text Editor
This program is blocking log out.
Waiting for program to finish.
Interrupting program may cause you to
lose work.

This didn't used to happen -- gnome would happily log out with Emacs running.

Also, the dialog stays up even if I exit out of emacs.
Comment 1 jmccann 2008-08-15 18:16:58 EDT
The not noticing the client going away is now fixed in upstream svn.  Still seems to be a problem that emacs blocks logout even if there are no unsaved buffers.
Comment 2 jmccann 2008-08-19 20:09:48 EDT
Indeed, emacs is requesting Interact whether or not it has unsaved buffers.

See smc_save_yourself_CB() in:
 http://cvs.savannah.gnu.org/viewvc/emacs/src/xsmfns.c?root=emacs&view=markup
Comment 3 Matthias Clasen 2008-08-23 19:55:24 EDT
So lets move this bug to where it belongs then, I guess.
Comment 5 Bug Zapper 2008-11-25 21:41:13 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Daniel Novotny 2009-09-21 07:41:30 EDT
this seems to be OK in F11 and F12, after Emacs update to 23.1

Note You need to log in before you can comment on or make changes to this bug.