This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 458255 - Evolution stopped coloring messages according to their labels after upgrade from Fedora 8 to 9
Evolution stopped coloring messages according to their labels after upgrade f...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-07 06:29 EDT by Tadej Janež
Modified: 2008-08-07 12:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-07 12:13:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Evolution not coloring messages according to label color (337.31 KB, image/png)
2008-08-07 08:50 EDT, Tadej Janež
no flags Details

  None (edit)
Description Tadej Janež 2008-08-07 06:29:05 EDT
Description of problem:
I use a Dovecot IMAP server for my INBOX (I don't know whether message labels are stored locally or on the server). I regularly assign different labels to messages.
After upgrading my system from Fedora 8 to Fedora 9 and thus also upgrading Evolution, the messages in my INBOX are no longer colored according to the colors assigned to their labels.
There are 2 exceptions, though:
1) Two *unread* labeled messages are displayed in the right color.
2) Messages with newly assigned labels display in their correct color.

Version-Release number of selected component (if applicable):
evolution-2.22.3.1-1.fc9.i386
evolution-data-server-2.22.3-2.fc9.i386

Steps to Reproduce:
1. Label messages with Fedora 8's Evolution (on a remote IMAP server)
2. Upgrade to Fedora 9's Evolution
3. Messages are not displayed in any color anymore
  
Actual results:
Messages with labels don't get colored correctly

Expected results:
Messages with labels should be colored according to their label's color

Additional info:
I didn't know where to report this bug. If you wish, I can also report it upstream.
Comment 1 Milan Crha 2008-08-07 07:41:36 EDT
That's ok. I believe that should work, as long as your flags has been on the server, then it should be properly downloaded and shown in the F9 box. Stored labels are not much back compatible with those in F8, though.
Can you add a "Labels" column to the view and check whether the old messages has something filled there or not? I guess they gone somehow (maybe wasn't properly saved on the imap server from F8?) Hard to say, at the moment.
Comment 2 Tadej Janež 2008-08-07 08:49:02 EDT
(In reply to comment #1)
> Can you add a "Labels" column to the view and check whether the old messages
> has something filled there or not? I guess they gone somehow (maybe wasn't
> properly saved on the imap server from F8?) Hard to say, at the moment.

I added the "Labels" column and captured a screenshot (see the attachment). Notice the messages labeled "Studies" showing in correct color and two messages below labeled as "Personal, Personal" (why the duplication?) and showing in black instead of green.

So, the labels are there, only the colors are missing.
Comment 3 Tadej Janež 2008-08-07 08:50:24 EDT
Created attachment 313690 [details]
Evolution not coloring messages according to label color
Comment 4 Milan Crha 2008-08-07 08:59:10 EDT
Ahh, the duplication causes this, if it has more than one label, then it doesn't color. It doesn't expect to have set one label more than once. And it should not too. I'm afraid that there is no better solution than to create a search folders, for any label, and fix it yourself, by select/unselect that label.

I cannot imagine how that could happen, did you touch the file with double Personal anyhow since the update to F9?
Comment 5 Milan Crha 2008-08-07 09:29:09 EDT
I tried to reproduce, but no luck. I can set Labels in the old evolution and it's properly recognized in the new one, no duplication. Even the code seems fine on the first look.
Comment 6 Tadej Janež 2008-08-07 12:13:12 EDT
I don't know how this could happen either. One thing I must note is that I've been using this system since Red Hat Linux 9. And I've always upgraded to the next version, e.g., RH9 -> FC1 -> FC2 ->..., so there is a lot of legacy in this system (I always clean up things after an upgrade though).

Thank you for the tip about creating search folder and unselecting/selecting the label. This fixed things for me!

For the record, I didn't touch anything between upgrade from F8 to F9.

I don't have an issue with this anymore, so this is fixed for me.

If you want to investigate things further, I'll be glad to cooperate.

Note You need to log in before you can comment on or make changes to this bug.