Bug 458260 - rpmbuild does not set exit code on error
rpmbuild does not set exit code on error
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
: 458261 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-07 07:16 EDT by Stepan Kasal
Modified: 2013-07-02 19:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-07 08:54:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stepan Kasal 2008-08-07 07:16:41 EDT
Though an error was reported, rpmbuild exits with exit code 0.


Version-Release number of selected component (if applicable):
rpm-4.5.90-0.git8426.9.i386

How reproducible: deterministic

Steps to Reproduce:
I made a typo in my foo.spec:
Patch4: foo-fourth.patch
Patch4: foo-fifth.patch
...
%patch4
%patch5

Then I ran "rpmbuild -bp foo.spec".

There was an error that no Patch5 has been declared, but then %patch5 expanded to nothing and processing happilly continued, until the prep script finished with "exit 0", which became the exit code of the whole rpmbuild command.

Carelessness in the extreme form!  "Don't worry, be happy!"
Comment 1 Jindrich Novy 2008-08-07 07:45:08 EDT
*** Bug 458261 has been marked as a duplicate of this bug. ***
Comment 2 Jindrich Novy 2008-08-07 08:54:35 EDT
Fixed upstream. This bug and #458261 annoyed me as well :) Fixed RPM should occur in rawhide with the new git snapshot.

Note You need to log in before you can comment on or make changes to this bug.