Bug 458261 - rpmbuild does not print any error if a PatchX or SourceX is defined multiple times
rpmbuild does not print any error if a PatchX or SourceX is defined multiple ...
Status: CLOSED DUPLICATE of bug 458260
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-07 07:20 EDT by Stepan Kasal
Modified: 2008-08-07 07:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-07 07:45:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stepan Kasal 2008-08-07 07:20:39 EDT
No error is reported if, e.g., two lines declare Patch4.

Version-Release number of selected component (if applicable):
rpm-4.5.90-0.git8426.9.i386

How reproducible: deterministic

Steps to Reproduce:
I made a typo in my foo.spec:
Patch4: foo-fourth.patch
Patch4: foo-fifth.patch
...
%patch4

Then I ran "rpmbuild -bp foo.spec".

There was no errror/warning about the duplicate Patch4 declaration; the second one silently overridden the previous one.
Comment 1 Jindrich Novy 2008-08-07 07:45:08 EDT

*** This bug has been marked as a duplicate of bug 458260 ***

Note You need to log in before you can comment on or make changes to this bug.