Bug 458262 - Installation of Fedora Rawhide failing
Installation of Fedora Rawhide failing
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ppc64 All
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-07 07:20 EDT by IBM Bug Proxy
Modified: 2008-10-15 03:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-23 10:25:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-08-07 07:20:47 EDT
=Comment: #0=================================================
Rene Schulze <rschulze@de.ibm.com> - 2008-07-03 04:27 EDT
Hi all,
I tried to http-install a IBM QS22 from my mirrored fedora development tree.
Using the ppc64.img to boot the via tftp, the system loads down the stage2.img,
starts anaconda 11.4.1.9, goes through the menu, writes the new partions and
after that the install crashes with following error-message:

                                                                                
         ┌─────────────────────────┤ Error ├──────────────────────────┐         
         │                                                            │         
         │ Unable to read package metadata. This may be due to a      │         
         │ missing repodata directory.  Please ensure that your       │         
         │ install tree has been correctly generated.                 │         
         │                                                            │         
         │ Cannot retrieve repository metadata (repomd.xml) for       │         
         │ repository: rawhide. Please verify its path and try again  │         
         │                                                            │        
s.fedoraproject.org/mirrorlist?repo=rawhide&arch=ppc error was
         │    ┌────────────────┐        ┌──────┐        ┌───────┐     │        
                                                              [Errno 4] IOError:
<url │    │ Exit installer │        │ Edit │        │ Retry │     │         
         │    └────────────────┘        └──────┘     Yum└───────┘r: Al│ mirror
URLs are not using ftp, http[s] or file.
         │                                                            │        
                                        Eg. 
         │                                                            │         
         └────────────────────────────────────────────────────────────┘         
                                                                                
                                                                                
                                                                                

  <Tab>/<Alt-Tab> between elements   |  <Space> selects   |  <F12> next screen 


The crash could be reproduced.

Best regards
Rene
=Comment: #6=================================================
Anoop V. Chakkalakkal <anoop.vijayan@in.ibm.com> - 2008-07-14 05:32 EDT
Please provide the yum configuration specific to the development version
repository which you are trying to install. The file normally resides as
/etc/yumrepos.d/*.repo if not /etc/yum.conf in the repo server. Thanks!
=Comment: #7=================================================
Rene Schulze <rschulze@de.ibm.com> - 2008-07-16 07:59 EDT
(In reply to comment #6)
Hi, the yum-stuff taken from stage2.img:

[root@elba5 ~]# mount -t squashfs -o loop stage2.img mydir/
[root@elba5 ~]# cd mydir/
[root@elba5 mydir]# ls
etc  firmware  lib  modules  proc  usr  var
[root@elba5 mydir]# cd etc/
[root@elba5 etc]# ls
dbus-1    fonts  gtk-2.0  joe          libuser.conf  mke2fs.conf    pango  
pcmcia     prelink.conf  rpm      services  udev  yum.repos.d
fb.modes  group  hal      ld.so.cache  man.config    nsswitch.conf  passwd 
PolicyKit  protocols     selinux  shells    yum
[root@elba5 etc]# cd yum.repos.d/
[root@elba5 yum.repos.d]# ls
fedora-rawhide.repo  fedora.repo  fedora-updates.repo  fedora-updates-testing.repo
[root@elba5 yum.repos.d]# cat *
# These packages are untested and still under development. This
# repository is used for development of new releases.
#
# This repository can see significant daily turnover and major
# functionality changes which cause unexpected problems with other
# development packages. Please use these packages if you want to work
# with the Fedora developers by testing these new development packages.
#
# fedora-test-list@redhat.com is available as a discussion forum for
# testing and troubleshooting for development packages in conjunction
# with new test releases.
#
# More information is available at http://fedoraproject.org/wiki/Testing 
#
# Reproducible and reportable issues should be filed at
# http://bugzilla.redhat.com/.
#
# Product: Fedora
# Version: rawhide

[rawhide]
name=Fedora - Rawhide
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/development/$basearch/os/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=rawhide&arch=$basearch
enabled=1
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-test-$basearch
file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

[rawhide-debuginfo]
name=Fedora - Rawhide - Debug
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/development/$basearch/debug/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=rawhide-debug&arch=$basearch
enabled=0
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-test-$basearch
file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

[rawhide-source]
name=Fedora - Rawhide - Source
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/development/source/SRPMS/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=rawhide-source&arch=$basearch
enabled=0
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-test-$basearch
file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

[fedora]
name=Fedora $releasever - $basearch
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-$releasever&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

[fedora-debuginfo]
name=Fedora $releasever - $basearch - Debug
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/$basearch/debug/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-debug-$releasever&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

[fedora-source]
name=Fedora $releasever - Source
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/source/SRPMS/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-source-$releasever&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch
[updates]
name=Fedora $releasever - $basearch - Updates
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/$basearch/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-f$releasever&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

[updates-debuginfo]
name=Fedora $releasever - $basearch - Updates - Debug
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/$basearch/debug/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-debug-f$releasever&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

[updates-source]
name=Fedora $releasever - Updates Source
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/SRPMS/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-source-f$releasever&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch
[updates-testing]
name=Fedora $releasever - $basearch - Test Updates
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/testing/$releasever/$basearch/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-testing-f$releasever&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-test-$basearch

[updates-testing-debuginfo]
name=Fedora $releasever - $basearch - Test Updates Debug
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/testing/$releasever/$basearch/debug/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-testing-debug-f$releasever&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-test-$basearch

[updates-testing-source]
name=Fedora $releasever - Test Updates Source
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/testing/$releasever/SRPMS/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-testing-source-f$releasever&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-test-$basearch
[root@elba5 yum.repos.d]# 

=Comment: #9=================================================
Anoop V. Chakkalakkal <anoop.vijayan@in.ibm.com> - 2008-07-23 05:55 EDT
Okay, I managed to recreate it locally. What happens is, the installer tries to
access the url http://mirrors.fedoraproject.org/mirrorlist?repo=rawhide&arch=ppc
and if it succeeds, picks up one of the repositories listed out in the page and
then would probably go ahead downloading the packages and install them online.

If you don't have an internet connection, it fails and this is the situation here.

Here it gives an option to edit the repo URL. (I was using VNC, so not sure if
this option is displayed in a text mode install) If you point it to your local
repository (http://..../development/ppc/os) then installation will proceed.

I am not sure if this is the expected behavior or a bug, since it the
development version. (But, what if you are connected to the net but still want
to use your local repo). We can discuss on this once you confirm the issue is
resolved using the above mentioned workaround.
=Comment: #12=================================================
Anoop V. Chakkalakkal <anoop.vijayan@in.ibm.com> - 2008-08-06 07:08 EDT
http://fedoraproject.org/wiki/Releases/Rawhide says -
Installation of Rawhide
Rawhide is meant to be installable, however, since it's automated, any
particular rawhide build may not be installable due to bugs of one sort or another.
Comment 1 Andy Lindeberg 2008-08-07 09:59:18 EDT
The Rawhide you're using is about a month and a half old. Can you retry with a more recent version?
Comment 2 IBM Bug Proxy 2008-08-07 10:10:39 EDT
(In reply to comment #17)
> ------- Comment From alindebe@redhat.com 2008-08-07 09:59:18 EDT-------
> The Rawhide you're using is about a month and a half old. Can you retry with a
more recent version?

Hi,

some printouts from yesterday:

0 > boot net
...
+------------------------+ URL Setup +-------------------------+
|                                                              |
|         Please enter the URL containing the Fedora           |
|         images on your server.                               |
|                                                              |
| http://10.96.0.1/fedora_dev_ppc_____________________________ |
|                                                              |
|            +----+                       +------+             |
|            | OK |                       | Back |             |
|            +----+                       +------+             |
|                                                              |
|                                                              |
+--------------------------------------------------------------+
...
+----------------------------+ Retrieving +----------------------------+
|                                                                      |
| Retrieving stage2.img...                                             |
|                                                                      |
+----------------------------------------------------------------------+

...

Running anaconda 11.4.1.24, the Fedora system installer - please wait...

...

Same behavior as shown in the older version.

Regards Rene
Comment 3 Chris Lumens 2008-08-11 11:23:33 EDT
Can you attach /tmp/anaconda.log to this bug report?
Comment 4 IBM Bug Proxy 2008-08-20 03:50:30 EDT
(In reply to comment #19)
> ------- Comment From clumens@redhat.com 2008-08-11 11:23:33 EDT-------
> Can you attach /tmp/anaconda.log to this bug report?

Hi,

I'm sorry, can't give you any log, because I do have only one console and this
one dies...

Regards Rene
Comment 5 Chris Lumens 2008-08-26 15:27:28 EDT
If you've got a machine on the network that can be a remote syslog server, you can have the anaconda log file sent over to it.  Just add syslog=host[:port] to your boot arguments and once you get to stage2, anaconda will log everything remotely.  You can then pull the messages off your server and attach them to this bug report.
Comment 6 IBM Bug Proxy 2008-08-28 03:00:25 EDT
(In reply to comment #21)
> ------- Comment From clumens@redhat.com 2008-08-26 15:27:28 EDT-------

Hi, thanks for your hint. I'll try it as soon as the stage2.img will contain a
driver to use my BLOCK-DEV: "STEC 8GB USB 1.00" 8.39 GB [mfd/disk0] (as it was
contained in earlier releases) to install the fedora on it...
Best regards Rene
Comment 7 Chris Lumens 2008-09-04 17:01:19 EDT
I don't know what kind of device that is, nor what driver supports it.  Any help?
Comment 8 IBM Bug Proxy 2008-09-10 11:10:32 EDT
(In reply to comment #24)
sorry for late response: the driver for the usb-connected flash-drive is
missing, cant create any partitions
Comment 9 Chris Lumens 2008-09-23 10:25:58 EDT
I still have no idea what kind of device you are trying to install from, so I can't check to make sure we include a valid driver for it or anything.  If you can help with identifying the device and its proper driver, maybe there's something we can do here.
Comment 10 IBM Bug Proxy 2008-10-15 03:41:46 EDT
Closing to reflect external status and plan change

Note You need to log in before you can comment on or make changes to this bug.