Bug 458298 - Cannot create new cluster in luci, python syntax error
Cannot create new cluster in luci, python syntax error
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: conga (Show other bugs)
4
All Linux
medium Severity high
: rc
: ---
Assigned To: Ryan McCabe
Brian Brock
:
: 497437 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-07 11:14 EDT by Matthew Whitehead
Modified: 2010-10-22 23:33 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-25 16:36:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Whitehead 2008-08-07 11:14:30 EDT
Description of problem: Cannot create new cluster in luci, python syntax error


Version-Release number of selected component (if applicable): luci-0.11.1-5.el4


How reproducible: 100%


Steps to Reproduce:
1. On a new machine start luci
2. Try to create a new cluster
3. It will generate a python error
  
Actual results: Python error


Expected results: Create the cluster


Additional info:

Here is the code diff from 'refried' on IRC #cluster

/var/lib/luci/Extensions/HelperFunctions.py

<       if not os_str or os_str.find('Tikanga') != (-1) or os_str.find('Zod') != (-1) or os_str.find('Moonshine') != (-1) or os_str.find('Werewolf') != (-1) or os.str_find('Sulphur') != (-1):
---
>       if not os_str or os_str.find('Tikanga') != (-1) or os_str.find('Zod') != (-1) or os_str.find('Moonshine') != (-1) or os_str.find('Werewolf') != (-1) or os_str.find('Sulphur') != (-1):
Comment 1 Nate Straz 2008-11-05 12:14:12 EST
Just to make the intent of the diff clear, the problem is around the check for "Sulphur."  The code should read "os_str.find" instead of "os.str_find"
Comment 10 Ryan McCabe 2008-12-10 16:39:23 EST
You can find updated packages at /mnt/redhat/brewroot/scratch/rmccabe/task_1607985 for clustermon and /mnt/redhat/brewroot/scratch/rmccabe/task_1608000 for luci and ricci
Comment 13 Brian Brock 2009-04-29 16:55:32 EDT
fix verified in luci-0.11.2-2.el4

clusters are created without syntax errors
Comment 14 Ryan McCabe 2009-04-30 11:57:56 EDT
*** Bug 497437 has been marked as a duplicate of this bug. ***
Comment 16 errata-xmlrpc 2009-05-25 16:36:18 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1063.html

Note You need to log in before you can comment on or make changes to this bug.