Bug 458371 - GIMP destroys tiff-files when saved via network on an NFS Server
GIMP destroys tiff-files when saved via network on an NFS Server
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
8
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-07 16:17 EDT by Thomas Schanz
Modified: 2008-08-08 12:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-08 11:59:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Schanz 2008-08-07 16:17:26 EDT
Description of problem:
The gimp-program destroys tiff-file when they are saved via network on an NFS
server! If you save a picture from gimp via network on a NFS-server the file
is written without any complains but the data of the picture will be destroyed.

(Better try not to modify your beloved holiday pictures from gimp via NFS or
they are all gone, ...ask someone who did ...)

The problem occur on an Fedora 4 NFS-Server as well as on an HPUX 11.i 
NFS server so it seems to me the server is not responsible. The problem 
occurs only on saving tiff-files, other file types seem not be affected.

Version-Release number of selected component (if applicable):

fedora 2.6.23.1-42.fc8 (32bit)
gimp-2.4.0-0.rc3.2.fc8
libtiff-3.8.2-9.fc8

How reproducible:

always

Steps to Reproduce:

1.open a tiff with GIMP that is hosted on an NFS-server of your choice 
via network 
2.modify something if you like and save it back on the NFS-Server again
3.open the file again and scratch your neck
  
Actual results:

you should warn your users

Expected results:

fix the bug

Additional info:
Comment 1 Gian Paolo Mureddu 2008-08-07 19:18:46 EDT
Since this also seems to affect 64-bit (x86) platforms, wouldn't it be better to expand on the platform affected to all? See this thread on fedoraforum.org:
http://forums.fedoraforum.org/showthread.php?t=186489
Comment 2 Nils Philippsen 2008-08-08 05:01:44 EDT
You seem to use the non-updated package versions as contained in the installation media. There have been quite a number of updates which could affect you here, namely gimp-2.4.6-1.fc8 and kernel-2.6.25.11-60.fc8.

Do you see this problem with all current updates installed (after making a backup)?
Comment 3 Thomas Schanz 2008-08-08 11:47:31 EDT
Hello and thanks for the quick reply!

the here reported bug seems to be fixed by now.

Meanwhile I have installed all updates that were available for my
system and the problem is fixed by now. Unfortunately I had no time
to install the patched one after another. All I can say is that it 
was not fixed by the gimp-update nor the nfs-patches. I assume the
kernel-module ubdate did the job but I'am not shure about that.

So far I can live with the result except of the pictures I have lost ;-).
thanks again,
Thomas.
Comment 4 Thomas Schanz 2008-08-08 12:39:34 EDT
now it looks like a kernel bug of the old 2.6.23.1-42.fc8 kernel! 

Because the old kernel is still intact after the kernel upgrade I have booted
the updated system with the old kernel 2.6.23.1-42.fc8 and the bug is alive 
again! 

If I boot the system with the new kernel 2.6.25.11-60.fc8 instead, GIMP works
correct via NFS and the tiffs are alright.

Note You need to log in before you can comment on or make changes to this bug.