Bug 458427 - prelink fail over grass-libs
prelink fail over grass-libs
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: grass (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Balint Cristian
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-08 02:47 EDT by Balint Cristian
Modified: 2008-09-14 02:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-14 02:51:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Balint Cristian 2008-08-08 02:47:13 EDT
Description of problem:

Dear Cristian !

I've just noticed that on the fc9 systems I'm looking after, the current 
grass-libs package interferes with correct operation of prelink - 
resulting in a creeping performance degradation after a while...

/var/log/prelink/prelink.log  reports:

/usr/sbin/prelink -av -mR -f
/usr/sbin/prelink: /usr/lib/libgrass_gproj.so.6.3.0 has a dependency cycle
Laying out 1081 libraries in virtual address space 00101000-50000000
Random base 0x011c6000
/usr/sbin/prelink: Could not find virtual address slot for 
/usr/lib/libgrass_sim.so.6.3
Prelink failed with return value 1


grass itself seems to be running ok and I did not have the time yet to 
investigate the root cause of the problem - the cyclic dependency in 
libgrass_gproj seems to be through gdal, while the missing slot for 
libgrass_sim seems to be the real show-stopper for prelink.


As a quick-fix (ie. to have prelink work again while investigating the 
grass problem, I would recommend to blacklist the two suspect libraries 
for prelink, e.g. by creating /etc/prelink.conf.d/grass.conf  with the 
content

-b /usr/lib/libgrass_gproj.so.6.3.0
-b /usr/lib/libgrass_sim.so.6.3

and adding it to the package.

Hope that makes sense ... cheers,
Wolfgang
Comment 1 Balint Cristian 2008-08-08 02:54:51 EDT
 Dont know if its prelink fault, or grass-lib missbehave,
but if Jakub have the time to look over would be great, 
otherwise i'll accept to fix by blacklist as Wolfgang
suggested.

 Jakub, would you comment a bit ?

//cristian.
Comment 2 Balint Cristian 2008-08-26 09:43:09 EDT
- solved in devel.

Investigate why koji fail for build-f9.
Comment 3 Fedora Update System 2008-09-12 01:29:15 EDT
grass-6.3.0-6.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/grass-6.3.0-6.fc9
Comment 4 Fedora Update System 2008-09-14 02:51:03 EDT
grass-6.3.0-6.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.