Bug 458447 - KDE applications don't see shared CUPS printers on the network
KDE applications don't see shared CUPS printers on the network
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-08 10:06 EDT by David Jansen
Modified: 2008-09-05 14:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-05 14:25:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jansen 2008-08-08 10:06:01 EDT
Description of problem:
On our network, we have a couple of machines with a printer, that is shared using CUPS, and a central printserver (RHEL 4) shares queus for some network printers outside the local network. On the desktop system (Fedora 8 & 9), CUPS is configured to look at this central print server, and all queues are thus available to all systems. This works fine for lpr, and most applications.
However, in KDE 3.x (Fedora 8), no printers are shown (unless there is a local printer, then that printer is available in the dialog, and if Cups-pdf is installed, it also shows up in the dialog). In Fedora 9, the printers are visible from kde applications (and others).

Version-Release number of selected component (if applicable):
kdebase-3.5.9-7.fc8
kdelibs-3.5.9-5.fc8
(but: downgrading to the original 3.5.8 that came with Fedora 8 didn't solve the problem)
Comment 1 Rex Dieter 2008-08-08 10:16:55 EDT
Odd, we do about the same thing at our site (using BrowsePoll), works fine.

Does
/etc/printcap 
contain anything?
(Hint, that's bascially what's used to pre-populate kde's list of available printers).
Comment 2 David Jansen 2008-08-08 10:25:34 EDT
Contents of /etc/printcap on my desktop (which has Cups-pdf and a local printer):

# This file was automatically generated by cupsd(8) from the
# /etc/cups/printers.conf file.  All changes to this file
# will be lost.
david_desk|David's printer:rm=schelde.strw.leidenuniv.nl:rp=david_desk:
Cups-PDF|Cups-PDF:rm=schelde.strw.leidenuniv.nl:rp=Cups-PDF:

So no mention there of the network printers seen by cups. E.g.:
$ lpstat -a
Cups-PDF accepting requests since Sun 03 Aug 2008 04:11:24 MEST
david_desk accepting requests since Thu 07 Aug 2008 15:07:01 MEST
frank_desk accepting requests since Tue 05 Aug 2008 23:02:56 MEST
hp1 accepting requests since Fri 08 Aug 2008 08:45:48 MEST
hp4 accepting requests since Sun 03 Aug 2008 04:11:29 MEST
hp5 accepting requests since Fri 08 Aug 2008 14:39:36 MEST

(and many more)
Comment 3 Rex Dieter 2008-09-05 11:32:15 EDT
I cannot reproduce this, bouncing over to the smart cups folks to see if they have any advice/insight about the disparity of /etc/printcap vs lpstat -a output
Comment 4 Tim Waugh 2008-09-05 11:44:27 EDT
What do these say?

  ls -l /etc/printcap
  ls -Z /etc/printcap
Comment 5 David Jansen 2008-09-05 14:02:45 EDT
schelde:jansen [~] $ ls -l /etc/printcap 
-rw-r--r-- 1 root root 268 2008-08-13 14:49 /etc/printcap
schelde:jansen [~] $ ls -Z /etc/printcap
-rw-r--r--  root root                                  /etc/printcap
(SELinux is off)

But: I managed to solve the problem myself, by removing and reinstalling kdebase and kdelibs. Quite strange, a couple of machines in our network had this problem, and in all cases, the reinstall solved the problem.

So as far as I am concerned, we can consider this issue closed. And I'm sorry I forgot to close this issue once I solved the problem.
Comment 6 Rex Dieter 2008-09-05 14:25:46 EDT
Glad to hear you got it working.

Closing.

Note You need to log in before you can comment on or make changes to this bug.