Bug 458490 - libcurl.so.3 same ABI as libcurl.so.4
libcurl.so.3 same ABI as libcurl.so.4
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: curl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-08 16:50 EDT by Warren Togami
Modified: 2008-08-12 00:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-12 00:56:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2008-08-08 16:50:21 EDT
According to Debian, they have libcurl.so.3 as a symlink to libcurl.so.4 because upstream screwed up and they are actually the same ABI.  The only thing that changed is that some things from .3 are now deprecated.

http://blogs.adobe.com/penguin.swf/2008/08/library_expansion.html
This will soon become an issue for us as Adobe will release Flash 10 with a link to libcurl.so.3.

We could do better than a symlink.

Nalin recommended writing an empty dummy library named libcurl.so.3 that links to libcurl.so.4.  This would make RPM do the right thing and provide the correct so-names in both archs of the package.

I will write this myself and with your permission push it to Fedora Updates for 8 and higher.
Comment 1 Jindrich Novy 2008-08-12 00:56:57 EDT
Hi Warren, spot has already applied the soname fix in rawhide. Hopefully, it will work.

Note You need to log in before you can comment on or make changes to this bug.