Bug 458501 - Misleading yumdownloader error message with nonexistent --enablerepo
Misleading yumdownloader error message with nonexistent --enablerepo
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-08 17:51 EDT by Ville Skyttä
Modified: 2008-08-16 04:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-16 04:44:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2008-08-08 17:51:22 EDT
$ yumdownloader --enablerepo=doesnotexist foo
Loaded plugins: fastestmirror
Cannot handle specific enablerepo/disablerepo options.

This error message is very misleading.  Unless I'm mistaken, yumdownloader can indeed handle such options; the actual problem in this case is instead that the "doesnotexist" repo does not exist.

yum-utils-1.1.14-4.fc9.noarch
yum-3.2.17-2.fc9.noarch
Comment 1 Tim Lauridsen 2008-08-16 04:44:32 EDT
Fixed upstream.

now you will get this one.
$ yumdownloader --disablerepo=dummy foo
Loaded plugins: refresh-packagekit
Error getting repository data for dummy, repository not found

Note You need to log in before you can comment on or make changes to this bug.