Bug 458572 - Package Kit does not accept smart package manager as a backend
Package Kit does not accept smart package manager as a backend
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-10 02:16 EDT by Scott Williams
Modified: 2008-08-18 05:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-18 05:03:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Williams 2008-08-10 02:16:29 EDT
Description of problem:

Package kit does not allow smart as a backend.  Message when running packagekitd --backend smart:

TI:02:12:53	TH:0x90c0458	FI:pk-main.c	FN:main,266
 - cannot continue, backend invalid

Version-Release number of selected component (if applicable):

smart-0.52-54.fc9.i386
packagekit - 0.2.3

How reproducible:

Every time.

Steps to Reproduce:
1.Install smart package manager (smart)
2.run: packagekitd --backend smart
3.observe issue described above
  
Actual results:

User is not able to use smart as a backend.

Expected results:

User may use alternate package managers that support rpm as backends.

Additional info:

n/a
Comment 1 Richard Hughes 2008-08-11 03:20:45 EDT
I've not turned on the smart backend as it's not been tested at all in Fedora. Could you please checkout the PackageKit source code and build it with smart support and then test all the GUI tools please? Thanks.
Comment 2 Scott Williams 2008-08-11 10:16:35 EDT
I grabbed the source RPM and can see smart is an available backend in the source.  When I went to ./configure, I got the following dependencies missing:

No package 'glib-2.0' found
No package 'gobject-2.0' found

Current glib version is glib-1.2.10-29.fc9.i386 and yum whatprovides returns nothing for gobject or */gobject.

How would you recommend resolving these dependencies, so I can test the smart backend?

If you already have the build environment, would you mind attaching the compiled test rpm here?
Comment 3 Scott Williams 2008-08-11 12:43:52 EDT
Here's the output of where ./configure breaks:

checking for GLIB... configure: error: Package requirements (glib-2.0 >= 2.14.0 gobject-2.0) were not met:

No package 'glib-2.0' found
No package 'gobject-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GLIB_CFLAGS
and GLIB_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

[scott@localhost PackageKit-0.2.3]$ rpm -q glib
glib-1.2.10-29.fc9.i386


Using PackageKit-0.2.3-6.fc9.src.rpm
Comment 4 Richard Hughes 2008-08-18 05:03:51 EDT
I think you need to join the mailing list, where there are other PackageKit developers available there to help you out. I don't have the time to test and maintain another backend in Fedora, but if you can show me that there is someone willing to do it then I will gladly turn on the backend. I'll close for now.

Note You need to log in before you can comment on or make changes to this bug.