Bug 458609 - designer crashes on start up
designer crashes on start up
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-10 17:17 EDT by Andrew Parker
Modified: 2009-01-09 18:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 18:11:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Parker 2008-08-10 17:17:11 EDT
Description of problem:
designer seg faults on start up

Version-Release number of selected component (if applicable):
qt-devel-4.4.1-2.fc10.i386


How reproducible:


Steps to Reproduce:
1.  run designer
2.
3.
  
Actual results:
$ designer
Segmentation fault


Expected results:


Additional info:
This is on a fully up to date rawhide system

Program received signal SIGSEGV, Segmentation fault.
0x0323482d in ?? () from /usr/lib/libQtDesignerComponents.so.4
(gdb) bt
#0  0x0323482d in ?? () from /usr/lib/libQtDesignerComponents.so.4
#1  0x032d566a in ?? () from /usr/lib/libQtDesignerComponents.so.4
#2  0x032d5829 in ?? () from /usr/lib/libQtDesignerComponents.so.4
#3  0x032db18f in ?? () from /usr/lib/libQtDesignerComponents.so.4
#4  0x032329bc in QDesignerComponents::createPropertyEditor () from /usr/lib/libQtDesignerComponents.so.4
#5  0x08083e19 in ?? ()
#6  0x0807a15b in ?? ()
#7  0x0807e36b in ?? ()
#8  0x0807316e in QMenu::addMenu ()
#9  0x08073833 in QMenu::addMenu ()
#10 0x080721a6 in QMenu::addMenu ()
#11 0x007996e5 in __libc_start_main () from /lib/libc.so.6
#12 0x0805ac71 in QMenu::addMenu ()
Comment 1 Kevin Kofler 2008-08-10 17:23:10 EDT
Oh fun, another blocker pops up. :-(
Comment 2 Kevin Kofler 2008-08-10 17:27:41 EDT
Qt 4 Designer works for me with qt4-4.4.1-2.fc8. Is this a Rawhide-only issue?
Comment 3 Andrew Parker 2008-08-10 17:43:49 EDT
And this time with debuginfo

Program received signal SIGSEGV, Segmentation fault.
QtAbstractPropertyBrowser::topLevelItems (this=<value optimized out>)
    at ../../../../shared/qtpropertybrowser/qtpropertybrowser.cpp:1722
1722        return d_ptr->m_topLevelIndexes;
Missing separate debuginfos, use: debuginfo-install OpenEXR.i386 bzip2.i386 cups.i386 dbus.i386 e2fsprogs.i386 expat.i386 fontconfig.i386 freetype.i386 gcc.i386 glib2.i386 glibc.i686 gnutls.i386 ilmbase.i386 jasper.i386 kdebase-runtime.i386 kdelibs.i386 keyutils.i386 krb5.i386 lcms.i386 libICE.i386 libSM.i386 libX11.i386 libXau.i386 libXcursor.i386 libXdamage.i386 libXdmcp.i386 libXext.i386 libXfixes.i386 libXft.i386 libXi.i386libXinerama.i386 libXpm.i386 libXrandr.i386 libXrender.i386 libXtst.i386 libXxf86vm.i386 libcap.i386 libdrm.i386 libgcrypt.i386 libgpg-error.i386 libjpeg.i386 libmng.i386 libpng.i386 libselinux.i386 libtasn1.i386 libtiff.i386 libxcb.i386 mesa.i386 openssl.i686 sqlite.i386 zlib.i386
(gdb) bt
#0  QtAbstractPropertyBrowser::topLevelItems (this=<value optimized out>)
    at ../../../../shared/qtpropertybrowser/qtpropertybrowser.cpp:1722
#1  0x032d566a in qdesigner_internal::PropertyEditor::updateColors (this=<value optimized out>)
    at ../propertyeditor/propertyeditor.cpp:690
#2  0x032d5829 in qdesigner_internal::PropertyEditor::updateForegroundBrightness (
    this=<value optimized out>) at ../propertyeditor/propertyeditor.cpp:588
#3  0x032db18f in PropertyEditor (this=<value optimized out>, core=<value optimized out>,
    parent=<value optimized out>, flags=<value optimized out>) at ../propertyeditor/propertyeditor.cpp:283
#4  0x032329bc in QDesignerComponents::createPropertyEditor (core=<value optimized out>,
    parent=<value optimized out>) at qdesigner_components.cpp:233
#5  0x08083e19 in QDesignerPropertyEditor (this=0x8827c68, workbench=0x81ce6d0)
    at qdesigner_propertyeditor.cpp:60
#6  0x0807a15b in QDesignerWorkbench::initialize (this=0x81ce6d0) at qdesigner_workbench.cpp:375
#7  0x0807e36b in QDesignerWorkbench (this=0x81ce6d0) at qdesigner_workbench.cpp:195
#8  0x0807316e in QDesigner::initialize (this=0xbffff1f4) at qdesigner.cpp:214
#9  0x08073833 in QDesigner (this=0xbffff1f4, argc=@0xbffff240, argv=0xbffff2c4) at qdesigner.cpp:98
#10 0x080721a6 in main (argc=135449480, argv=0xaaaaffff) at main.cpp:70
Comment 4 Rex Dieter 2008-08-11 00:44:18 EDT
I can't reproduce on F-9 either (using qt-4.4.1-1.fc9 anyway)
Comment 5 Kevin Kofler 2008-08-11 07:49:15 EDT
Taking this off the Qt44 tracker again.
Comment 6 Steven M. Parrish 2008-08-12 11:53:40 EDT
Works fine for me in F9 and Rawhide
Comment 7 Andrew Parker 2008-08-13 14:02:13 EDT
I have 2 raw hide systems, both up to date, one exhibits the crash, one doesn't.  I synced them up so that had the same RPMs installed, but still only one system crashed.

As of last night's updates (which didn't include qt) I don't get the crash on either system any more.  X doesn't start up now, but that's a different problem.

I assume that this can be closed now?
Comment 8 Kevin Kofler 2008-08-13 14:40:32 EDT
Looks like it. We can reopen it if it happens again.
Comment 9 Kevin Kofler 2008-08-18 13:01:49 EDT
Reopening, fengshaun on #fedora-kde can reproduce it.
Comment 10 Bug Zapper 2008-11-25 21:43:54 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Steven M. Parrish 2009-01-09 15:43:33 EST
I am still unable to recreate this on my systems.  Can anyone reproduce with a current F10 install?
Comment 12 Andrew Parker 2009-01-09 18:02:44 EST
I can't reproduce it any more.
Comment 13 Steven M. Parrish 2009-01-09 18:11:38 EST
Thanks for the prompt reply.

Note You need to log in before you can comment on or make changes to this bug.