Bug 458619 - CA_PROP_MEDIA_FILENAME doesn't work
CA_PROP_MEDIA_FILENAME doesn't work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libcanberra (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-10 23:39 EDT by Matthias Clasen
Modified: 2008-08-23 20:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-23 20:43:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2008-08-10 23:39:27 EDT
Bastien added code to play sounds as preview in the file chooser, using CA_PROP_MEDIA_FILENAME, but it doesn't work. Looking at the libcanberra
code, ca_lookup_sound handles it fine, but we never get that far since
ca_context_play_full returns an error with

    ca_return_val_if_fail_unlock(ca_proplist_contains(p, CA_PROP_EVENT_ID) ||
                                 ca_proplist_contains(c->props, CA_PROP_EVENT_ID), CA_ERROR_INVALID, c->mutex);
Comment 1 Lennart Poettering 2008-08-17 11:49:25 EDT
This is fixed in Rawhide, theoretically at least, since I am unable to build it, since koji is down.
Comment 2 Matthias Clasen 2008-08-23 20:43:54 EDT
Fixed in rawhide, sound preview works now.

Note You need to log in before you can comment on or make changes to this bug.