Bug 45865 - texconfig fails without tetex-xdvi installed
Summary: texconfig fails without tetex-xdvi installed
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tetex   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 38751 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-25 19:14 UTC by Rex Dieter
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-07 21:02:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2001:166 normal SHIPPED_LIVE Updated teTeX packages available 2001-12-11 05:00:00 UTC

Description Rex Dieter 2001-06-25 19:14:57 UTC
Description of Problem:
Using texconfig to configure tetex fails when tetex-xdvi is not installed.

I use texconfig to set default paper size for example:
> texconfig dvips paper letter


How Reproducible:
Always.

Steps to Reproduce: (Start with tetex-xdvi installed)
1. texconfig dvips paper letter (works)
2. rpm -e tetex-xdvi
3. texconfig dvips paper letter (Failure/error)

Actual Results:
texconfig error: "Could not find app-default file for xdvi"

Expected Results:
It should work.

Comment 1 Rex Dieter 2001-06-25 19:37:41 UTC
The easiest fix, IMO, would be to include the XDvi app-defaults file in the
tetex-fonts rpm (tetex-xdvi depends upon tetex-fonts already anyway).

Otherwise, patch texconfig to not require the presence of XDvi (at least when
configuring non-XDvi tetex options).  I spent about 15 minutes trying to do
this, but didn't find an easy/clean way to do it.

For the record, I didn't want to bother installing tetex-xdvi because we're
using KDE's kdvi exclusively anyway.

Comment 2 Tim Waugh 2001-09-30 20:54:32 UTC
*** Bug 38751 has been marked as a duplicate of this bug. ***

Comment 3 Tim Waugh 2001-10-22 08:51:27 UTC
Fixed in tetex-1.0.7-33.



Note You need to log in before you can comment on or make changes to this bug.