Bug 458702 - kdump initrd hangs waiting on cciss or md devices
kdump initrd hangs waiting on cciss or md devices
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Neil Horman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-11 13:28 EDT by Doug Chapman
Modified: 2009-01-20 15:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:59:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to exclude md and cciss from critical_disks (615 bytes, patch)
2008-08-11 13:28 EDT, Doug Chapman
no flags Details | Diff
updated patch to properly handle raid cases (1.64 KB, patch)
2008-08-11 15:17 EDT, Doug Chapman
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0105 normal SHIPPED_LIVE kexec-tools bug fix and enhancement update 2009-01-20 11:04:36 EST

  None (edit)
Description Doug Chapman 2008-08-11 13:28:00 EDT
Created attachment 313983 [details]
patch to exclude md and cciss from critical_disks

Description of problem:
The recent changes to kdump mkdumprd to wait until the needed devices are in place before mounting the root filesystem hangs on md or cciss devices.  This is due to how it parses the devices to be able to find them in sysfs.

Since these devices are always there once the driver is loaded we don't have the race condition issue so the easiest is to just exclude them from etc/critical_disks.

I am attaching a patch to mkdumprd that does that.  Patch has been tested on systems with "md" and "cciss" disks.

Version-Release number of selected component (if applicable):
kexec-tools-1.102pre-31


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 RHEL Product and Program Management 2008-08-11 14:23:39 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Doug Chapman 2008-08-11 15:17:45 EDT
Created attachment 313995 [details]
updated patch to properly handle raid cases

In the process of looking at this we also found that for raid devices it does not add the /dev/sd* devices needed to critical_disks as it should.  This is an updated patch that has the fix mentioned in the orignal comment and also fixes this raid case.

This has been tested on 3 different ia64 systems with these configs:

lvm on top of raid on scsi disks
raid on scsi disks
lvm on top of cciss disks


all appear to kdump properly and inspection of etc/critical_disks shows what is expected (the needed sd disks only).
Comment 3 Neil Horman 2008-08-12 06:47:21 EDT
fixed in -32.el5.  Thanks!
Comment 4 Doug Chapman 2008-08-18 14:09:07 EDT
Neil,

Thanks, I have verified that -32.el5 does indeed work nicely.

- Doug
Comment 8 errata-xmlrpc 2009-01-20 15:59:38 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0105.html

Note You need to log in before you can comment on or make changes to this bug.