Bug 458817 - archivesize is 0
archivesize is 0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-12 10:19 EDT by Michael Schwendt
Modified: 2008-08-13 03:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-13 03:07:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2008-08-12 10:19:04 EDT
$ rpm -qp --qf "%{archivesize}\n" \
NetworkManager-gnome-0.7.0-0.11.svn3930.fc10.ppc.rpm 
0

This happens only for ppc/ppc64 builds of binaries and source rpms.

Rawhide and RPMFusion are affected. At RPMFusion the zero size
was discovered in the repoview pages for the powerpc repos.

The zero archive size also finds its way into the repository
metadata (primary.*) and the source rpms repo metadata, too.
Look for archive=0 attr in "size" tags.

To reproduce, download any recent build made on the powerpc builders.
Comment 1 Panu Matilainen 2008-08-12 11:48:57 EDT
Ugh. Will look into this asap...
Comment 2 Panu Matilainen 2008-08-13 03:07:14 EDT
Ok, fixed both upstream and in rawhide (rpm-4.5.90-0.git8461.2). Now to figure how many packages need a rebuild because of this...

Note You need to log in before you can comment on or make changes to this bug.