Bug 458819 - Error from tests.spec010.SpecTest.testMessageProperties on rhel4
Error from tests.spec010.SpecTest.testMessageProperties on rhel4
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: python-qpid (Show other bugs)
1.0
All Linux
urgent Severity medium
: 1.0.1
: ---
Assigned To: messaging-bugs
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-12 10:20 EDT by Gordon Sim
Modified: 2008-08-12 11:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-12 11:43:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Sim 2008-08-12 10:20:21 EDT
======================================================================
ERROR: testMessageProperties (tests.spec010.SpecTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/remote/gsim/qpid.0-10/python/tests/spec010.py", line 55, in testMessageProperties
    dec = self.encdec(mp, props)
  File "/home/remote/gsim/qpid.0-10/python/tests/spec010.py", line 44, in encdec
    type.encode(sc, value)
  File "/home/remote/gsim/qpid.0-10/python/qpid/spec010.py", line 241, in encode
    self.encode_fields(sc, value)
  File "/home/remote/gsim/qpid.0-10/python/qpid/spec010.py", line 256, in encode_fields
    f.type.encode(codec, values[f.name])
  File "/home/remote/gsim/qpid.0-10/python/qpid/spec010.py", line 147, in encode
    getattr(codec, "write_%s" % self.name)(value)
  File "/home/remote/gsim/qpid.0-10/python/qpid/codec010.py", line 98, in write_uint64
    self.pack("!Q", n)
  File "/home/remote/gsim/qpid.0-10/python/qpid/packer.py", line 36, in pack
    self.write(struct.pack(fmt, *args))
TypeError: can't convert negative long to unsigned

----------------------------------------------------------------------
Comment 1 Gordon Sim 2008-08-12 11:43:05 EDT
Not a bug: just an issue with the way the test specifies the literal value (its a hex literal which is getting interpreted as a signed int). using an equiavlent decimal literal in the test works fine.

Note You need to log in before you can comment on or make changes to this bug.