Bug 458830 - Accessibility: Bugzilla's private vs. public comments aren't.
Accessibility: Bugzilla's private vs. public comments aren't.
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
All Linux
low Severity low (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-12 11:23 EDT by Lon Hohberger
Modified: 2013-06-23 22:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-13 14:40:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2008-08-12 11:23:58 EDT
Description of problem:

Previous versions of bugzilla had an obvious color separation between public and private comments that even red/green colorblind people, such as myself, could see immediately and easily.

The current version of bugzilla's CSS makes the comment boxes 240/232/232 for private comments and 232/232/232 for normal comments.  This difference is indistinguishable to me, which greatly slows down my ability to read bugzillas quickly.

The text (dark red) is almost passable, but I need to look pretty hard to see the difference unless I increase the font size.

Contrast to the old style of 'white' background turning to 'gray' when a comment was private - the color / shade difference was immediate and obvious.
Comment 1 Lon Hohberger 2008-08-12 11:29:04 EDT
Changing to classic skin fixes this for me.  So, I'm marking this as low severity/priority.
Comment 2 David Lawrence 2008-08-12 17:24:14 EDT
I have updated the RedHat css to turn the comment background to white. Please take a look at our internal test instance.

https://bz-web2-test.devel.redhat.com

Let me know if it is better that way.

Dave
Comment 4 Lon Hohberger 2008-08-13 14:00:48 EDT
The input field for new comments changes color when I check/uncheck the 'private' checkbox, but previous comment boxes still look the same.

http://people.redhat.com/lhh/color-sshot.png 

Looking at bug #1 on the aforementioned bugzilla incarnation w/ the RedHat skin selected.  I added a test comment; private and non-private boxes still look gray to me unless I missed something.
Comment 5 David Lawrence 2008-08-13 14:15:01 EDT
(In reply to comment #4)
> The input field for new comments changes color when I check/uncheck the
> 'private' checkbox, but previous comment boxes still look the same.
> 
> http://people.redhat.com/lhh/color-sshot.png 
> 
> Looking at bug #1 on the aforementioned bugzilla incarnation w/ the RedHat skin
> selected.  I added a test comment; private and non-private boxes still look
> gray to me unless I missed something.

My fault. I was testing something different on our test server and accidently pulled my fix for this bug out of the code. I have put it back now so please look again.

https://bz-web2-test.devel.redhat.com

Dave
Comment 6 Lon Hohberger 2008-08-13 14:29:41 EDT
In the updated style sheet, I can tell the difference very clearly.  I was even able to notice on a second read that one Mr. Laska had previously added a test private comment to bug #1 in the aforementioned bugzilla instance (which I *totally* missed the first time looking at it!).
Comment 7 David Lawrence 2008-08-13 14:40:22 EDT
Ok, will add to the next update later this week.

Dave
Comment 8 Lon Hohberger 2008-08-13 14:42:56 EDT
If you want to try other color or UI combinations as well, I'll assist in any way I can.  The difference doesn't need to be quite that pronounced.

Even 'a bit darker' for private comments would be okay as well (say 212/204/204 instead of 240/232/232), even if the public comments are left the same.

However, since I'm colorblind, I don't know if that slight red tinge on the slightly darker gray makes non-color-blind people's heads hurt... ;)

Just some thoughts.
Comment 9 David Lawrence 2008-08-13 14:52:37 EDT
Originally on our last Bugzilla, normal comments had a white background and private ones had a pinkish/red background. So we will just go back to that since noone complained about the colors before now :)

Dave

Note You need to log in before you can comment on or make changes to this bug.