Bug 458832 - multiple plugin error dialogs at startup
multiple plugin error dialogs at startup
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhythmbox (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Bastien Nocera
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-12 11:43 EDT by Cameron Meadors
Modified: 2009-01-20 17:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 17:14:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace -vvv rhythmbox (2.35 MB, text/plain)
2008-08-13 12:43 EDT, Cameron Meadors
no flags Details

  None (edit)
Description Cameron Meadors 2008-08-12 11:43:36 EDT
When I start rhythmbox for a new user I get "Plugin error" dialogs.  One for each plugin that is missing:

Audio CD player
Portable Players
Jamendo
Magnatune Store
Cover Art

Here is the output from the command line:

$ rhythmbox
ImportError: could not import gst
Traceback (most recent call last):
  File "/usr/lib/rhythmbox/plugins/artdisplay/__init__.py", line 323, in ?
    class ArtDisplayPlugin (rb.Plugin):
AttributeError: 'module' object has no attribute 'Plugin'

(rhythmbox:7012): Rhythmbox-WARNING **: Could not load plugin artdisplay


(rhythmbox:7012): Rhythmbox-WARNING **: Error, impossible to activate plugin 'Cover art'
Traceback (most recent call last):
  File "/usr/lib/rhythmbox/plugins/magnatune/__init__.py", line 40, in ?
    from MagnatuneSource import MagnatuneSource
  File "/usr/lib/rhythmbox/plugins/magnatune/MagnatuneSource.py", line 56, in ?
    class MagnatuneSource(rb.BrowserSource):
AttributeError: 'module' object has no attribute 'BrowserSource'

(rhythmbox:7012): Rhythmbox-WARNING **: Could not load plugin magnatune


(rhythmbox:7012): Rhythmbox-WARNING **: Error, impossible to activate plugin 'Magnatune Store'
Traceback (most recent call last):
  File "/usr/lib/rhythmbox/plugins/jamendo/__init__.py", line 36, in ?
    from JamendoSource import JamendoSource
  File "/usr/lib/rhythmbox/plugins/jamendo/JamendoSource.py", line 45, in ?
    class JamendoSource(rb.BrowserSource):
AttributeError: 'module' object has no attribute 'BrowserSource'

(rhythmbox:7012): Rhythmbox-WARNING **: Could not load plugin jamendo


(rhythmbox:7012): Rhythmbox-WARNING **: Error, impossible to activate plugin 'Jamendo'

(rhythmbox:7012): Rhythmbox-WARNING **: /usr/lib/rhythmbox/plugins/generic-player/libgeneric-player.so: cannot restore segment prot after reloc: Permission denied

(rhythmbox:7012): Rhythmbox-WARNING **: Could not load plugin generic-player


(rhythmbox:7012): Rhythmbox-WARNING **: Error, impossible to activate plugin 'Portable Players'

(rhythmbox:7012): Rhythmbox-WARNING **: Unable to grab media player keys: Method "GrabMediaPlayerKeys" with signature "su" on interface "org.gnome.SettingsDaemon" doesn't exist


(rhythmbox:7012): Rhythmbox-WARNING **: /usr/lib/rhythmbox/plugins/audiocd/libaudiocd.so: cannot restore segment prot after reloc: Permission denied

(rhythmbox:7012): Rhythmbox-WARNING **: Could not load plugin audiocd


(rhythmbox:7012): Rhythmbox-WARNING **: Error, impossible to activate plugin 'Audio CD Player'

(rhythmbox:7012): GLib-GObject-WARNING **: cannot register existing type `TotemPlParser'

(rhythmbox:7012): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(rhythmbox:7012): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(rhythmbox:7012): GLib-GObject-CRITICAL **: g_signal_connect_object: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(rhythmbox:7012): GLib-GObject-CRITICAL **: g_object_set: assertion `G_IS_OBJECT (object)' failed

(rhythmbox:7012): GLib-GObject-WARNING **: cannot register existing type `TotemPlParser'

** (rhythmbox:7012): CRITICAL **: totem_pl_parser_parse_with_base: assertion `TOTEM_IS_PL_PARSER (parser)' failed

(rhythmbox:7012): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
Comment 1 Cameron Meadors 2008-08-12 11:50:36 EDT
using rhythmbox-0.11.6-1.2.el5_2
Comment 2 RHEL Product and Program Management 2008-08-12 11:52:15 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Bastien Nocera 2008-08-13 06:39:29 EDT
(In reply to comment #0)
> When I start rhythmbox for a new user I get "Plugin error" dialogs.  One for
> each plugin that is missing:
> 
> Audio CD player
> Portable Players
> Jamendo
> Magnatune Store
> Cover Art
> 
> Here is the output from the command line:
> 
> $ rhythmbox
> ImportError: could not import gst
> Traceback (most recent call last):
>   File "/usr/lib/rhythmbox/plugins/artdisplay/__init__.py", line 323, in ?
>     class ArtDisplayPlugin (rb.Plugin):
> AttributeError: 'module' object has no attribute 'Plugin'
> 
> (rhythmbox:7012): Rhythmbox-WARNING **: Could not load plugin artdisplay
> 
> 
> (rhythmbox:7012): Rhythmbox-WARNING **: Error, impossible to activate plugin
> 'Cover art'
> Traceback (most recent call last):
>   File "/usr/lib/rhythmbox/plugins/magnatune/__init__.py", line 40, in ?
>     from MagnatuneSource import MagnatuneSource
>   File "/usr/lib/rhythmbox/plugins/magnatune/MagnatuneSource.py", line 56, in ?
>     class MagnatuneSource(rb.BrowserSource):
> AttributeError: 'module' object has no attribute 'BrowserSource'
> 
> (rhythmbox:7012): Rhythmbox-WARNING **: Could not load plugin magnatune
> 
> 
> (rhythmbox:7012): Rhythmbox-WARNING **: Error, impossible to activate plugin
> 'Magnatune Store'
> Traceback (most recent call last):
>   File "/usr/lib/rhythmbox/plugins/jamendo/__init__.py", line 36, in ?
>     from JamendoSource import JamendoSource
>   File "/usr/lib/rhythmbox/plugins/jamendo/JamendoSource.py", line 45, in ?
>     class JamendoSource(rb.BrowserSource):
> AttributeError: 'module' object has no attribute 'BrowserSource'
> 
> (rhythmbox:7012): Rhythmbox-WARNING **: Could not load plugin jamendo
> 
> 
> (rhythmbox:7012): Rhythmbox-WARNING **: Error, impossible to activate plugin
> 'Jamendo'

All those are due to the problem importing the gst module

> (rhythmbox:7012): Rhythmbox-WARNING **:
> /usr/lib/rhythmbox/plugins/generic-player/libgeneric-player.so: cannot restore
> segment prot after reloc: Permission denied
> 
> (rhythmbox:7012): Rhythmbox-WARNING **: Could not load plugin generic-player

SELinux error.

> (rhythmbox:7012): Rhythmbox-WARNING **: Error, impossible to activate plugin
> 'Portable Players'
> 
> (rhythmbox:7012): Rhythmbox-WARNING **: Unable to grab media player keys:
> Method "GrabMediaPlayerKeys" with signature "su" on interface
> "org.gnome.SettingsDaemon" doesn't exist

I should probably remove that bit from the code, as I don't think the gnome-settings-daemon we ship in RHEL 5 supports the D-Bus multimedia keys interface.

> (rhythmbox:7012): Rhythmbox-WARNING **:
> /usr/lib/rhythmbox/plugins/audiocd/libaudiocd.so: cannot restore segment prot
> after reloc: Permission denied
> 
> (rhythmbox:7012): Rhythmbox-WARNING **: Could not load plugin audiocd
> 
> 
> (rhythmbox:7012): Rhythmbox-WARNING **: Error, impossible to activate plugin
> 'Audio CD Player'

Another SELinux error.

> (rhythmbox:7012): GLib-GObject-WARNING **: cannot register existing type
> `TotemPlParser'
> 
> (rhythmbox:7012): GLib-GObject-CRITICAL **: g_object_new: assertion
> `G_TYPE_IS_OBJECT (object_type)' failed
> 
> (rhythmbox:7012): GLib-GObject-WARNING **: invalid (NULL) pointer instance
> 
> (rhythmbox:7012): GLib-GObject-CRITICAL **: g_signal_connect_object: assertion
> `G_TYPE_CHECK_INSTANCE (instance)' failed
> 
> (rhythmbox:7012): GLib-GObject-CRITICAL **: g_object_set: assertion
> `G_IS_OBJECT (object)' failed
> 
> (rhythmbox:7012): GLib-GObject-WARNING **: cannot register existing type
> `TotemPlParser'
> 
> ** (rhythmbox:7012): CRITICAL **: totem_pl_parser_parse_with_base: assertion
> `TOTEM_IS_PL_PARSER (parser)' failed
> 
> (rhythmbox:7012): GLib-GObject-CRITICAL **: g_object_unref: assertion
> `G_IS_OBJECT (object)' failed

That might be a problem with my totem-pl-parser glib backports.
Comment 5 Bastien Nocera 2008-08-13 08:49:09 EDT
Should be fixed in rhythmbox-0.11.6-1.4.el5_2
Comment 6 Cameron Meadors 2008-08-13 12:43:13 EDT
Created attachment 314220 [details]
strace -vvv  rhythmbox
Comment 7 Cameron Meadors 2008-08-13 12:46:15 EDT
Comment on attachment 314220 [details]
strace -vvv  rhythmbox

wrong bug
Comment 12 errata-xmlrpc 2009-01-20 17:14:45 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0242.html

Note You need to log in before you can comment on or make changes to this bug.