Bug 458834 - selinux denial for libgeneric-player.so
selinux denial for libgeneric-player.so
Status: CLOSED DUPLICATE of bug 458836
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.2.z
All Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-12 11:49 EDT by Cameron Meadors
Modified: 2008-08-12 13:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-12 13:20:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cameron Meadors 2008-08-12 11:49:05 EDT
When I start rhythmbox (0.11.6-1.2.el5_2) I get the following selinux denial:

SELinux is preventing rhythmbox from loading /usr/lib/rhythmbox/plugins/generic-player/libgeneric-player.so which requires text relocation. 

host=hp-dc5700-02.rhts.bos.redhat.com type=AVC msg=audit(1218555257.272:20): avc: denied { execmod } for pid=7012 comm="rhythmbox" path="/usr/lib/rhythmbox/plugins/generic-player/libgeneric-player.so" dev=dm-0 ino=10881165 scontext=user_u:system_r:unconfined_t:s0 tcontext=system_u:object_r:lib_t:s0 tclass=file host=hp-dc5700-02.rhts.bos.redhat.com type=SYSCALL msg=audit(1218555257.272:20): arch=40000003 syscall=125 success=no exit=-13 a0=71fd000 a1=22000 a2=5 a3=bfb63030 items=0 ppid=6457 pid=7012 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=pts1 ses=1 comm="rhythmbox" exe="/usr/bin/rhythmbox" subj=user_u:system_r:unconfined_t:s0 key=(null)
Comment 1 RHEL Product and Program Management 2008-08-12 11:52:11 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Cameron Meadors 2008-08-12 11:58:41 EDT
changing component to selinux-policy and ccing bnocera
Comment 3 Daniel Walsh 2008-08-12 13:19:32 EDT
Is this happening in an updated version of rhythmbox it is rhythmbox problem

Libraries should never need text  relocation.  Most likely a bug in the way they were built.
Comment 4 Daniel Walsh 2008-08-12 13:20:21 EDT

*** This bug has been marked as a duplicate of bug 458836 ***

Note You need to log in before you can comment on or make changes to this bug.