This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 458836 - selinux denial for libaudiocd.so
selinux denial for libaudiocd.so
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhythmbox (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Bastien Nocera
desktop-bugs@redhat.com
:
: 458834 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-12 11:55 EDT by Cameron Meadors
Modified: 2009-01-20 17:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 17:14:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cameron Meadors 2008-08-12 11:55:40 EDT
When I start rhythmbox (0.11.6-1.2.el5_2) I get the following selinux denial:

SELinux is preventing rhythmbox from loading /usr/lib/rhythmbox/plugins/audiocd/libaudiocd.so which requires text relocation. 

Raw Audit Messages :

host=hp-dc5700-02.rhts.bos.redhat.com type=AVC msg=audit(1218555257.486:21): avc: denied { execmod } for pid=7012 comm="rhythmbox" path="/usr/lib/rhythmbox/plugins/audiocd/libaudiocd.so" dev=dm-0 ino=10881136 scontext=user_u:system_r:unconfined_t:s0 tcontext=system_u:object_r:lib_t:s0 tclass=file 

host=hp-dc5700-02.rhts.bos.redhat.com type=SYSCALL msg=audit(1218555257.486:21): arch=40000003 syscall=125 success=no exit=-13 a0=6d52000 a1=d000 a2=5 a3=bfb63030 items=0 ppid=6457 pid=7012 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=pts1 ses=1 comm="rhythmbox" exe="/usr/bin/rhythmbox" subj=user_u:system_r:unconfined_t:s0 key=(null)
Comment 1 RHEL Product and Program Management 2008-08-12 12:12:25 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Daniel Walsh 2008-08-12 13:15:29 EDT
This should not be necessary.  If rhythmbox is shipping an update it built the library incorrectly.
Comment 3 Daniel Walsh 2008-08-12 13:16:00 EDT
chcon -t textrel_shlib_t /usr/lib/rhythmbox/plugins/audiocd/libaudiocd.so

Will fix the problem for now.
Comment 4 Daniel Walsh 2008-08-12 13:20:21 EDT
*** Bug 458834 has been marked as a duplicate of this bug. ***
Comment 5 Bastien Nocera 2008-08-13 08:48:22 EDT
Should be fixed in rhythmbox-0.11.6-1.4.el5_2
Comment 9 errata-xmlrpc 2009-01-20 17:14:47 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0242.html

Note You need to log in before you can comment on or make changes to this bug.