Bug 458890 - MogileFS looses files frequently
MogileFS looses files frequently
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: perl-MogileFS-Server (Show other bugs)
el5
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Ruben Kerkhof
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-12 18:46 EDT by Clint Goudie
Modified: 2008-08-13 11:18 EDT (History)
0 users

See Also:
Fixed In Version: perl-mogilefs-server-2_17-6_el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-13 11:18:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clint Goudie 2008-08-12 18:46:13 EDT
Description of problem:

Due to a problem in the tempfile handling, mogilefs occasionally 
 looses file data after a while.

Dormando from the mogilefs list has checked in a patch to address this issue: 

http://groups.google.com/group/mogile/browse_thread/thread/2eee02f6c64bf16f/8f6dfe269c21779b

Please roll this patch into the EPEL el5 RPM. It's not currently safe to use the mogilefs in the yum repo. (I imagine this is also true of the FC9 rpms)

Version-Release number of selected component (if applicable):
mogilefsd-2.17-5.el5

How reproducible:
It is difficult to reproduce, but has happened to our system frequently. Here are three threads that have explored the problem:

Specifically Cent5 with EPEL:
http://groups.google.com/group/mogile/browse_thread/thread/126b535b895fc4f8

Additional bug reports:
http://groups.google.com/group/mogile/browse_thread/thread/c737e84feea148e2/3ebdf130e57f12bb

http://lists.danga.com/pipermail/mogilefs/2008-June/001728.html


Steps to Reproduce:
To simulate the problem, you can manually insert an entry into tempfile like so:
INSERT INTO tempfile (fid,dmid,dkey,classid,devids,createtime) VALUES ('41','1','238','1','1','1');
with the fid and dkey values matching a file in your mogilefs store.
  
Actual results:
The files are deleted even if valid.

Expected results:
The files should not be deleted. (As discussed on the mogile lists)
Comment 1 Ruben Kerkhof 2008-08-13 11:18:30 EDT
Thanks,

Packages have just been build, they will be pushed with the next EPEL update

Note You need to log in before you can comment on or make changes to this bug.