Bug 458907 - System update fails with: iwl4965-firmware conflicts with kernel-smp-2.6.25.14-108.fc9.ppc
System update fails with: iwl4965-firmware conflicts with kernel-smp-2.6.25.1...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: iwl4965-firmware (Show other bugs)
9
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Nicolas Chauvet (kwizart)
Fedora Extras Quality Assurance
:
: 459097 459799 462310 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-12 23:58 EDT by Bob Reid
Modified: 2008-09-16 19:23 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-16 19:23:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error report dialog (21.69 KB, image/png)
2008-08-12 23:58 EDT, Bob Reid
no flags Details

  None (edit)
Description Bob Reid 2008-08-12 23:58:19 EDT
Created attachment 314170 [details]
error report dialog

Description of problem:
Normal system updating failing with "ERROR with rpm_check_debug vs depsolve:
iwl4965-firmware conflicts with kernel-smp-2.6.25.14-108.fc9.ppc"


Version-Release number of selected component (if applicable):
Unknown except as listed in the error.

How reproducible:
Always.

Steps to Reproduce:
1. Engage system updater after updates reported.
2. Update must be deselected from list for updating to continue.

  
Actual results:
Updating stops on dialog warning.

Expected results:
Normal resolution and install of the update.

Additional info:
Power Mac g4 MDD, dual 1.25GHz, 2GB RAM
Comment 1 Nicolas Chauvet (kwizart) 2008-08-13 04:32:27 EDT
There is nothing that conflict with kernel-smp in the iwl4965-firmware side.
This conflict should be explained in the kernel side. (will re-assign to the kernel once problem is found)

can you run (with the old iwl4965-firmware)
yum update --verbose
Comment 2 Bob Reid 2008-08-14 03:09:35 EDT
Loading "refresh-packagekit" plugin
Loaded plugins: refresh-packagekit
Config time: 0.379
Yum Version: 3.2.17
COMMAND: yum update --verbose 
Installroot: /
Reading Local RPMDB
rpmdb time: 0.001
Setting up Package Sacks
pkgsack time: 4.249
Setting up Update Process
Building updates object
up:Obs Init time: 1.501
putting python-genshi in complex update
putting kernel-smp in complex update
processing python-genshi
processing kernel-smp.ppc
up:simple updates time: 0.513
up:obs time: 0.014
up:condense time: 0.000
updates time: 6.626
Resolving Dependencies
--> Running transaction check
---> Package kernel-smp.ppc 0:2.6.25.14-108.fc9 set to be installed
Checking deps for kernel-smp.ppc 0-2.6.25.14-108.fc9 - i
looking for (u'/bin/sh', None, (None, None, None)) as a requirement of kernel-smp.ppc 0-2.6.25.14-108.fc9 - i
looking for (u'/bin/sh', None, (None, None, None)) as a requirement of kernel-smp.ppc 0-2.6.25.14-108.fc9 - i
looking for (u'module-init-tools', None, (None, None, None)) as a requirement of kernel-smp.ppc 0-2.6.25.14-108.fc9 - i
looking for (u'initscripts', u'GE', (u'0', u'8.11.1', u'1')) as a requirement of kernel-smp.ppc 0-2.6.25.14-108.fc9 - i
looking for (u'fileutils', None, (None, None, None)) as a requirement of kernel-smp.ppc 0-2.6.25.14-108.fc9 - i
looking for (u'mkinitrd', u'GE', (u'0', u'6.0.39', u'1')) as a requirement of kernel-smp.ppc 0-2.6.25.14-108.fc9 - i
--> Processing Conflict: kernel-smp conflicts iwl4965-firmware < 228.57.2
kernel-smp conflicts with iwl4965-firmware
--> Finished Dependency Resolution
Dependency Process ending
kernel-smp-2.6.25.14-108.fc9.ppc from updates has depsolving problems
  --> kernel-smp conflicts with iwl4965-firmware
--> Running transaction check
---> Package kernel-smp.ppc 0:2.6.25-14.fc9 set to be erased
Checking deps for kernel-smp.ppc 0-2.6.25-14.fc9 - e
--> Finished Dependency Resolution
Dependency Process ending
Depsolve time: 6.003

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 kernel-smp              ppc        2.6.25.14-108.fc9  updates            20 M
Removing:
 kernel-smp              ppc        2.6.25-14.fc9    installed          53 M

Transaction Summary
=============================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       1 Package(s)         

Total size: 20 M
Comment 3 Nicolas Chauvet (kwizart) 2008-08-14 04:10:13 EDT
@Linville

Any reason why we have Conflicts instead of Requires ?
Comment 4 John W. Linville 2008-08-14 10:27:00 EDT
I don't think I added that line, and I don't know enough about RPM to explain the difference between Conflicts and Requires anyway.

Any reason not to just update the iwl4965-firmware?
Comment 5 John W. Linville 2008-08-14 10:32:48 EDT
*** Bug 459097 has been marked as a duplicate of this bug. ***
Comment 6 Nicolas Chauvet (kwizart) 2008-08-29 07:13:17 EDT
*** Bug 459799 has been marked as a duplicate of this bug. ***
Comment 7 Nicolas Chauvet (kwizart) 2008-08-29 07:19:42 EDT
Sorry, I should have answered quicker.

As i remember there is no iwl4965.ko driver on recent ppc(64) kernel. Thus we decided to ExcludeArch: ppc ppc64 both iwl4965-firmware and the newly introduced iwl5000-firmware.

It could be "possible" to have iwl4965/iwl5000 kernel module to work on ppc. But as the module isn't built anymore on Fedora ppc kernels (confirmed ?). It doesn't really make sense to have Conflicts to the iwl*-firmware on ppc(64) kernels.

Now i don't know if this won't lead to a problem while talking about comps.xml. At least I think this was architecture agnostic last time I 've checked.

Maybe it will be easier to reintroduce iwl*-firmware for ppc, (even if there is no kernel module). So, I will follow advices here...
Comment 8 Arnd Bergmann 2008-09-01 07:44:04 EDT
I would suggest adding the package back for Fedora-9 ppc, but not for rawhide, this will enable all F-9 users to install important updates again without having to understand about this bug, though it might prevent automated updates from F-9 to F-10.

Alternatively, you could put the Conflicts: in the kernel spec file into '%ifnarch ppc ppc64', or even '%ifarch %{x86}'.
Comment 9 Chuck Ebbert 2008-09-05 04:53:05 EDT
Those wireless drivers are back in the rawhide ppc kernel as of the next build.
Comment 10 Nicolas Chauvet (kwizart) 2008-09-05 06:23:00 EDT

An updated iwl4965-firmware will be re-introduced in the ppc/ppc64 repositories then (along with the new iwl500-firmware).
Comment 11 Fedora Update System 2008-09-05 06:23:30 EDT
iwl4965-firmware-228.57.2.21-1.1 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/iwl4965-firmware-228.57.2.21-1.1
Comment 12 simon 2008-09-09 16:25:55 EDT
Hi There
I have seen a similar error in my new installation of FC9, I enclose the complete error message for everyone to see.
I will add I am new to Fedora, I am no Linux guru either, but am not afraid of getting my hands dirty if I need to.

ERROR with rpm_check_debug vs depsolve:
iwl4965-firmware conflicts with kernel-2.6.25.14-108.fc9.i686
libpackagekit.so.3 is needed by gnome-packagekit-0.1.12-12.20080430.fc9.i386

Please note I am running an AMD64 CPU with lots of memory, this is a workstation not a laptop, everything is relatively ordinary with the whole install, I did also choose KDE, I prefer it.

Best regards to all

Simon
Kent, UK
Comment 13 simon 2008-09-09 16:30:43 EDT
Hi There
I have seen a similar error in my new installation of FC9, I enclose the complete error message for everyone to see.
I will add I am new to Fedora, I am no Linux guru either, but am not afraid of getting my hands dirty if I need to.

ERROR with rpm_check_debug vs depsolve:
iwl4965-firmware conflicts with kernel-2.6.25.14-108.fc9.i686
libpackagekit.so.3 is needed by gnome-packagekit-0.1.12-12.20080430.fc9.i386

Please note I am running an AMD64 CPU with lots of memory, this is a workstation not a laptop, everything is relatively ordinary with the whole install, I did also choose KDE, I prefer it.

Best regards to all

Simon
Kent, UK
Comment 14 Fedora Update System 2008-09-11 12:57:20 EDT
iwl4965-firmware-228.57.2.21-1.1 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update iwl4965-firmware'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-7802
Comment 15 Nicolas Chauvet (kwizart) 2008-09-15 06:17:03 EDT
*** Bug 462310 has been marked as a duplicate of this bug. ***
Comment 16 Fedora Update System 2008-09-16 19:23:00 EDT
iwl4965-firmware-228.57.2.21-1.1 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.