Bug 458910 - Installer fails in booting on PS3
Installer fails in booting on PS3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
powerpc Linux
medium Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-13 00:30 EDT by Kazunori Asayama
Modified: 2008-11-12 17:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-11 21:08:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kazunori Asayama 2008-08-13 00:30:23 EDT
Description of problem:

The installer fails in booting on PLAYSTATION 3. It hangs silently just after the boot loader loads the kernel image, so it looks like it fails in booting the kernel in early stage.

Version-Release number of selected component (if applicable):

boot.iso 2008.08.12 (kernel-2.6.27-0.244.rc2.git1.fc10 ?)

How reproducible:

Every time.

Steps to Reproduce:
1. Insert boot disc (created by using boot.iso) into PS3
2. Boot PS3.
3. Type 'linux video=720p' on the boot loader's prompt (kboot).

Actual results:

The install disc hangs silently just after loading the kernel.

Expected results:

The kernel normally boots and the installer starts.

Additional info:
Comment 1 Kazunori Asayama 2008-08-13 00:32:18 EDT
A workaround patch below provided by Geoff may fix this problem:

  http://git.kernel.org/?p=linux/kernel/git/geoff/ps3-linux-patches.git;a=commit;h=38afc862fe863c430a29207b914a7ee64250a3a3
Comment 3 Chuck Ebbert 2008-09-05 03:50:42 EDT
When will those patches be merged into the upstream linux kernel?
Comment 4 Kazunori Asayama 2008-09-05 05:05:34 EDT
(In reply to comment #3)
> When will those patches be merged into the upstream linux kernel?

The ioremap fix has already been merged to the current 2.6.27-rc5.

Another one (patch for USB problem) has not yet. That was submitted to the linux-usb ML by Geoff and it seems under discussion (but no progress since Aug. 26).

    http://thread.gmane.org/gmane.linux.usb.general/7087/focus=9199
Comment 5 Kazunori Asayama 2008-09-10 03:53:05 EDT
(In reply to comment #4)
> Another one (patch for USB problem) has not yet. That was submitted to the

The USB problem still exists in the current installer's kernel (maybe 2.6.27-0.314.rc5.git9), so the anaconda hangs at the beginning of installation steps.

The ioremap problem has disappeared.
Comment 6 Geoff Levand 2008-09-12 13:14:21 EDT
I see the patch for the USB fix is in the F-9 kernel CVS:

cvs.fedora.redhat.com:/cvs/pkgs
kernel/F-9/linux-2.6-usb-fix-hcd-interrupt-disabling.patch

I guess the installer is using an older kernel without this patch.

-Geoff
Comment 7 Chuck Ebbert 2008-09-13 00:12:54 EDT
We were expecting the fix to get merged in 2.6.27 but it is stuck in the USB patch tree. Added the patch from F9 to rawhide.
Comment 8 Kazunori Asayama 2008-09-18 02:29:17 EDT
(In reply to comment #7)
> We were expecting the fix to get merged in 2.6.27 but it is stuck in the USB
> patch tree. Added the patch from F9 to rawhide.

The current kernel (2.6.27-0.329.rc6.git2.fc10) in the installer image seems to work in text mode. (though the installer doesn't work in graphical mode because of memory shortage.) Thank you.
Comment 9 Geoff Levand 2008-09-24 18:05:29 EDT
The fix 'USB: fix hcd interrupt disabling' was added to mainline 2.6.27 in commit 83a798207361cc26385187b2e71efa2b5d75de7f.

-Geoff
Comment 10 Dave Jones 2008-11-11 11:35:26 EST
So the current F10 snapshots boot fine on PS3?
Comment 11 Kazunori Asayama 2008-11-11 20:58:25 EST
Yes, it works. Thanks.
Comment 12 Geoff Levand 2008-11-12 17:23:01 EST
I installed from the Fedora 10 Preview DVD using text mode without trouble.

  'linux video=720p text install'

-Geoff

Note You need to log in before you can comment on or make changes to this bug.