Bug 458985 - nagios-plugins-procs is missing etime from ps command
nagios-plugins-procs is missing etime from ps command
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: nagios-plugins (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-13 12:21 EDT by G. Michael Carter
Modified: 2008-10-03 18:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-28 23:34:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description G. Michael Carter 2008-08-13 12:21:08 EDT
Description of problem:

check_procs -vvva 'test.sh' --metric=ELAPSED -w 10 -c 100

Always reports OK because the etime is blank.

proc#=0 uid=1001 vsz=5176 rss=1592 pid=29719 ppid=6775 pcpu=0.00 stat=S etime= prog=bash args=bash
S     0 29761 16069   5168  1580  0.0    20:03:33 bash            bash


After recompiling the plugin with:

./configure --with-ps-command="`which ps` -eo 's uid pid ppid vsz rss pcpu etime comm args'" \
            --with-ps-format='%s %d %d %d %d %d %f %s %s %n' \
            --with-ps-cols=10 \
            --with-ps-varlist='procstat,&procuid,&procpid,&procppid,&procvsz,&procrss,&procpcpu,procetime,procprog,&pos'


and running it again I get:
proc#=0 uid=1001 vsz=5176 rss=1592 pid=29719 ppid=6775 pcpu=0.00 stat=S etime=01:31:24 prog=bash args=bash
S     0 29761 16069   5168  1580  0.0    20:03:33 bash            bash
Comment 1 G. Michael Carter 2008-08-13 12:22:34 EDT
Just wanted to note this is also a problem on CentOS, Oracle Enterprise Linux, and Fedora 8 and 9.    Seems to be a global oversight which no one has noticed yet.
Comment 2 Mike McGrath 2008-09-28 23:34:30 EDT
Ok, this is all set.  I'll be pushing a build out later this evening.
Comment 3 Fedora Update System 2008-10-02 10:04:42 EDT
nagios-plugins-1.4.13-4.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/nagios-plugins-1.4.13-4.fc9
Comment 4 Fedora Update System 2008-10-02 10:05:37 EDT
nagios-plugins-1.4.13-4.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/nagios-plugins-1.4.13-4.fc8
Comment 5 Fedora Update System 2008-10-03 18:31:23 EDT
nagios-plugins-1.4.13-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2008-10-03 18:35:12 EDT
nagios-plugins-1.4.13-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.