Bug 459000 - Clarify CLVM requirements and setup and background
Clarify CLVM requirements and setup and background
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Documentation-cluster (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Steven J. Levine
Content Services Development
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-13 14:17 EDT by Steven J. Levine
Modified: 2009-08-19 23:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-25 18:31:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven J. Levine 2008-08-13 14:17:05 EDT
Description of problem:

A message came to linux-lvm from somebody who was unsure about how to set up basic LVM in a cluster. Jonathan Brassow suggested that the LVM manual might clarify the following questions:

- Where do I get clvmd?
- How do I set up?
- Do I need to set up an entire cluster if all I want is CLVM?

Looking at the LVM and the Cluster doc, there's no one single place that answers these specific questions simply. The LVM doc might do a better job of cross referencing.

This is the initial email:

> From: Jean Spirat <jeanspirat@squirk.org>
> Date: August 5, 2008 8:36:52 AM CDT
> To: linux-lvm@redhat.com
> Subject: [linux-lvm] the lvm shared storage question of the week
> Reply-To: LVM general discussion and development <linux-lvm@redhat.com>
>
> Hello there,
>
> Is there any hint or any links anyone could share for the use of lvm on an AOE storage (shared block device over the network). I wanted to know how to create lvm group on a device that is shared among several host.
>
>
> so i use debian 4 servers that acces a AOE target drive. The servers all mount the etherdrive and i want to use lvm to partition this 4Terabyte  block device in smaller chunck. what should be the best way to do that ?
>
> While googling about this i found  references to clvm but no documentation i could use on how to set it up. Is this the way to go ?
>
>
> regards,
> Jean.


This is the IRC exchange that between me and Jonathan B.:

<visegrips> "running LVM in a cluster"
* visegrips looks at that
<slevine> visegrips: Setup?  I'm not sure what specifically you mean. Installation?
<slevine> visegrips: Maybe differences between setup in a cluster and setup locally?
<visegrips> slevine, I am a user who has no clue  and just heard about LVM.
<visegrips> slevine, and CLVM
<visegrips> slevine, so I see the admin guide, but I still don't know what steps are
required to setup CLVM
<slevine> slevine: Well, as far as I know there's only the basic manual:
http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.2/html/Cluster_Logical_Volume_Manager/index.html
<slevine> visegrips: Section 1.3, right up front
http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.2/html/Cluster_Logical_Volume_Manager/LVM_Cluster_Overview.html
<visegrips> slevine, (see above)  Yes, I'm looking at the overview now...  I'll look
at the other one next
<slevine> visegrips: Cluster setup and installation in general should be in the cluster
documents. This is the section in the Cluster Administration Overview:
<slevine> http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.2/html/Cluster_Suite_Overview/s1-clvm-overview-CSO.html
<slevine> That is, the section on CLVM
<visegrips> slevine, I'll look at that, thanks.
<slevine> visegrips: And if you conclude that there's something we need that we do not
provide, we can look at adding that...
<visegrips> slevine, an extremely short skim of that page reveals that there is not much
detail there either...
<visegrips> slevine, I see mention of 'clvmd' and that it is important, but not
much about the init script or ... maybe I'm just looking for too much.
<slevine> visegrips: It sounds as if you're looking for procedural setup stuff
<visegrips> slevine, perhaps what we need is a simple reference to the cluster
manual from the LVM manual when CLVM is mentioned
<visegrips> slevine, the user needs to setup a cluster and do LVM operations...  each
manual punts when it comes to talking about the other subject, but perhaps they should
at least mention each other
<slevine> visegrips: Yes, the topics are definitely separated out. Adding a reference
in the text is of course simple.
<visegrips> slevine, If I want CLVM, and all I read in the manual is that
'clvmd' is important - where do I get that, and after I install, why is it complaining?
<visegrips> slevine, ... hmmm, it's complaining about this cluster stuff.  what
is that?  how do I set it up?  do I need to set up everything if all I want is CLVM?
<visegrips> etc.
<visegrips> slevine, I think most of the time we assume (probably correctly)
that users will use a shared FS with CLVM - therefore, they will stumble upon
all the info somehow.
<slevine> visegrips: How does a user know that all they want is CLVM? Because all they
want really is LVM in a cluster.
<visegrips> slevine, this line of discussion comes from a msg sent to linux-lvm today.
<slevine> visegrips: In any case, my note to myself: Beef up section on
running LVM in a cluster. We can get back in touch for more specifics.
<visegrips> k
<slevine> visegrips: Can you capture the message to linux-lvm and send it to me?
It sounds like a useful starting point for me.
<visegrips> slevine, enroute


<visegrips> slevine, well, we know the knowledge he's missing... It was just difficult for me to find documentation that would answer his questions specifically.  (i.e.  Where's the CLVM documenation?  How do I set it up?)  Not really a one-stop shop for that.
Comment 1 Steven J. Levine 2009-02-25 18:31:15 EST
I have updated the LVM manual for the RHEL 5.3 release to include this information.

Note You need to log in before you can comment on or make changes to this bug.