Bug 459020 - Need notification that reboot is required after update
Need notification that reboot is required after update
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-13 15:45 EDT by Christopher Beland
Modified: 2009-02-13 19:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 19:30:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
restart notifier (14.10 KB, image/png)
2008-08-15 04:27 EDT, Richard Hughes
no flags Details
2 screenshots: hover-over and click-on results (19.37 KB, image/png)
2009-01-15 12:52 EST, Christopher Beland
no flags Details

  None (edit)
Description Christopher Beland 2008-08-13 15:45:00 EDT
Today the "bug fix available" icon appeared on my upper Gnome panel.  I clicked on it and downloaded some RPM updates.  I happened to look through the details of the updates and notices that some of them (such as the new kernel) require an reboot to take effect, but I was never prompted to do so.  If I had just chosen "update" without examining any details, I never would have known.  There should be a pop-up or some other prompt for the benefit of novice or inattentive users.  Ideally, it would allow the option of rebooting now, scheduling an overnight reboot, or ignoring the warning.

gnome-packagekit-0.2.3-9.fc9.i386
Comment 1 Christopher Beland 2008-08-13 15:46:39 EDT
Bug 149692 and Bug 103962 address the same issue, though they are filed against non-Fedora products.
Comment 2 Richard Hughes 2008-08-15 04:27:30 EDT
Created attachment 314379 [details]
restart notifier

Don't you get the restart notifier in the notification area?
Comment 3 Christopher Beland 2008-08-15 08:42:24 EDT
No, and it took me about a day before I got around to rebooting after the update.
Comment 4 Mark Locascio 2008-08-23 12:37:11 EDT
I can confirm. I finally did an update on my F9 machine as well, and was surprised to see that there was no notification to reboot after updating the kernel.
Comment 5 Richard Hughes 2008-10-27 09:16:19 EDT
This is fixed in rawhide, I'll backport to updates-testing now.
Comment 6 Christopher Beland 2009-01-15 12:52:38 EST
Created attachment 329115 [details]
2 screenshots: hover-over and click-on results

I installed kernel-2.6.29-0.35.rc1.git4.fc11.x86_64 today using the GUI.  I got a yellow warning triangle in the notification area, with the hover-over popup "You will need to log off and log back on". Clicking on the triangle popped up a menu which offered to restart the computer or hide the icon.  Logging off and back on cleared the triangle, but it didn't boot the machine into the new kernel.  The hover-over menu is misleading; it should say that the machine needs to be restarted.
Comment 7 Christopher Beland 2009-02-07 19:52:15 EST
With today's Rawhide update, I got a message saying I needed to log out and back in, and a list of packages given as the reason for this, but once again even though a new kernel had been installed, I wasn't prompted to reboot.

I left my desktop alone after the update finished for several hours, and when I came back and de-activated the screen saver, the notification icon was gone.  I think it should remain until the user either logs out or explicitly dismisses the icon.
Comment 8 Richard Hughes 2009-02-09 09:06:23 EST
We don't get the restart-required(system) when you're using rawhide as we don't get the metadata from bohdi. We generate the restart-required(session) data in the daemon ourselves, and thus it's the best we can do. As soon as we switch to F11, the restart-required actions will work correctly.
Comment 9 Matthias Clasen 2009-02-13 19:30:37 EST
notabug then, I guess

Note You need to log in before you can comment on or make changes to this bug.