Bug 459026 - kit-nagios couldn’t be found
kit-nagios couldn’t be found
Status: CLOSED CURRENTRELEASE
Product: Red Hat HPC Solution
Classification: Red Hat
Component: nagios (Show other bugs)
5.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: OCS Support
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-13 15:56 EDT by Rafael Garabato
Modified: 2008-09-10 18:42 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.1rc
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 09:44:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rafael Garabato 2008-08-13 15:56:17 EDT
Description of problem:
After executting nagios kit installation script an error occurrs and the package is not installed.


Version-Release number of selected component (if applicable):
Red Hat 5.2; ocs-kit-nagios.noarch 2.12-2

How reproducible:
It should be reproducible

Steps to Reproduce:
1. See actual results
2.
3.
  
Actual results:
[root@redhathpc ~]# /opt/kusu/sbin/install-kit-nagios
Loading "rhnplugin" plugin
rhel-x86_64-server-5      100% |=========================| 1.4 kB    00:00
rhel-x86_64-server-hpc-5- 100% |=========================| 1.2 kB    00:00
No Match for argument kit-nagios
No Match for argument component-nagios-compute-v2_12
No Match for argument component-nagios-installer-v2_12
No Match for argument kusu-nagios-config
No Match for argument nagios-mem-plugin
No Match for argument nagios-plugins
No Match for argument nagios-plugins-apt
No Match for argument nagios-plugins-breeze
No Match for argument nagios-plugins-by_ssh
No Match for argument nagios-plugins-dhcp
No Match for argument nagios-plugins-dig
No Match for argument nagios-plugins-disk
No Match for argument nagios-plugins-disk_smb
No Match for argument nagios-plugins-dns
No Match for argument nagios-plugins-dummy
No Match for argument nagios-plugins-file_age
No Match for argument nagios-plugins-flexlm
No Match for argument nagios-plugins-game
No Match for argument nagios-plugins-hpjd
No Match for argument nagios-plugins-http
No Match for argument nagios-plugins-icmp
No Match for argument nagios-plugins-ide_smart
No Match for argument nagios-plugins-ircd
No Match for argument nagios-plugins-ldap
No Match for argument nagios-plugins-linux_raid
No Match for argument nagios-plugins-load
No Match for argument nagios-plugins-log
No Match for argument nagios-plugins-mailq
No Match for argument nagios-plugins-mrtg
No Match for argument nagios-plugins-mrtgtraf
No Match for argument nagios-plugins-mysql
No Match for argument nagios-plugins-nagios
No Match for argument nagios-plugins-nt
No Match for argument nagios-plugins-ntp
No Match for argument nagios-plugins-nwstat
No Match for argument nagios-plugins-oracle
No Match for argument nagios-plugins-overcr
No Match for argument nagios-plugins-perl
No Match for argument nagios-plugins-pgsql
No Match for argument nagios-plugins-ping
No Match for argument nagios-plugins-procs
No Match for argument nagios-plugins-real
No Match for argument nagios-plugins-rpc
No Match for argument nagios-plugins-sensors
No Match for argument nagios-plugins-smtp
No Match for argument nagios-plugins-snmp
No Match for argument nagios-plugins-ssh
No Match for argument nagios-plugins-swap
No Match for argument nagios-plugins-tcp
No Match for argument nagios-plugins-time
No Match for argument nagios-plugins-udp
No Match for argument nagios-plugins-ups
No Match for argument nagios-plugins-users
No Match for argument nagios-plugins-wave
nagios-2.12-1.el5.x86_64. 100% |=========================| 2.2 MB    00:12
nagios-plugins-nrpe-2.7-3 100% |=========================|  19 kB    00:00
nrpe-2.7-3.el5.x86_64.rpm 100% |=========================|  31 kB    00:00
Adding kit using kitops...
No kits found. Nothing to do.
Adding kit using repoman...
The kit 'nagios' could not be found
Running repoman...
Refreshing repo: rhel5_x86_64. This may take a while...


Expected results:


Additional info:
Comment 1 Nils Philippsen 2008-08-14 04:57:13 EDT
*** Bug 459029 has been marked as a duplicate of this bug. ***
Comment 2 Rafael Garabato 2008-08-14 08:38:58 EDT
I don't believe that this is a duplicate of 459029.
The problem with that bug was that php-common was missing, here the problem is that a kit is misssing.
Comment 3 Nils Philippsen 2008-08-14 09:13:39 EDT
(In reply to comment #2)
> I don't believe that this is a duplicate of 459029.
> The problem with that bug was that php-common was missing, here the problem is
> that a kit is misssing.

I typed in the wrong BZ number for which bug #459029 is a duplicate (which is bug #459023). I corrected that immediately aftewards, but that doesn't remove the comment in this bug ;-).
Comment 4 Keve Gabbert 2008-08-22 11:37:54 EDT
who owns resolving this BZ?  Please change from "new" to "assign" and actually assign to someone.
Do you need any more info?
Comment 5 Rafael Garabato 2008-09-01 16:38:40 EDT
Has this issue been analyzed?
Comment 6 OCS Support 2008-09-09 17:59:24 EDT
I've installed the nagios kit from the beta channel.  The kit installs without error, an the GUI is available through the URL.  Just need to figure out what to change the bug state to...
Comment 7 Rafael Garabato 2008-09-10 09:01:49 EDT
It is working. I don't have any more request for this bug. It can be closed from my side.

Just a question, the fix was done in the same version that had errors. I mean, the error was in version 2.12-2 and the fix is also in version 2.12-2. Which is the criteria to change the version info?
Comment 8 OCS Support 2008-09-10 09:44:05 EDT
I think at the start there was a missing package which prevented the installation.
We have also made changes in the component-* files to help make sure the right versions are installed.

The Beta channel has the fix, so presumably so will the release version.
Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.