Bug 459038 - java-jre kit
java-jre kit
Status: CLOSED CURRENTRELEASE
Product: Red Hat HPC Solution
Classification: Red Hat
Component: ocs (Show other bugs)
5.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: OCS Support
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-13 17:11 EDT by Rafael Garabato
Modified: 2008-09-10 18:45 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.1rc
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 18:45:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rafael Garabato 2008-08-13 17:11:01 EDT
Description of problem:
Platform OCS 5 comes with a java-jre kit which comes with a newer version of Java-jre

java version "1.6.0_06"
Java(TM) SE Runtime Environment (build 1.6.0_06-b02)
Java HotSpot(TM) 64-Bit Server VM (build 10.0-b22, mixed mode)

Red Hat 5.2 comes with 1.4 version. Some HPC components requires a newer version, it can be available through a kit or rpms.

Version-Release number of selected component (if applicable):
Red hat 5.2

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Nils Philippsen 2008-08-14 05:03:36 EDT
I'm not sure about this: do we ship components in the RHEL HPC channel that need Java?
Comment 2 Rafael Garabato 2008-08-15 13:35:06 EDT
(In reply to comment #1)
> I'm not sure about this: do we ship components in the RHEL HPC channel that
> need Java?

Sorry, ignore what I previously said :D. Is there a way to configure a plugin for that java version in firefox?
Comment 3 Mark Black 2008-08-15 16:49:59 EDT
> Description of problem:
> Platform OCS 5 comes with a java-jre kit which comes with a newer version of
> Java-jre

That's right OCS 5 comes with a java-jre kit, but what you are looking at
is not OCS 5, it is Red Hat HPC.

The Red Hat HPC edition has only open source packages.
Comment 4 Daniel Riek 2008-08-18 13:58:09 EDT
We have the JREs available in the Supplementary channel, so we could optionally install them. The only problem is, that the customer has to subscribe to the Supplementary RHN Channel, so it should fail gracefully if the JREs are not available.

In 5.3 we are going to add OpenJDK as an default alternative.
Comment 5 Rafael Garabato 2008-08-19 14:39:56 EDT
Ok, please ignore what I said here. I submit this "bug" for clarification only. There is not a problem. Should I close this bug?
Comment 6 Mark Black 2008-08-19 15:54:23 EDT
Would an OpenJDK kit solve the problem?  The installation paths will be different so the checker would need to deal with Java being in two different locations depending on which Java was available.
Comment 7 Rafael Garabato 2008-08-20 09:14:13 EDT
There is not a problem. The bug was for clarification.

Still I would like to know why Platforms delivers a Java Kit and does not use the java version that comes with Red Hat. This is the reason this "bug" exists (And I highlight bug because it is not a real bug :D).
Comment 8 OCS Support 2008-09-09 14:53:07 EDT
The beta channel now has the packages for the Java kit.  The Red Hat version of this kit requires that the installer node also be subscribed to the supplementary channel, from which it grabs the actual packages.  It also has the three different JRE's that are available from that channel
Comment 9 Daniel Riek 2008-09-10 18:45:33 EDT
Packages are available. Verified functionality in test installation.

Note You need to log in before you can comment on or make changes to this bug.