Bug 45906 - Xircom RealModule serial_cb is missing in kernel-2.4.3-12
Xircom RealModule serial_cb is missing in kernel-2.4.3-12
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-25 15:59 EDT by Bertil Askelid
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-06 00:03:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg for kernel-2.4.3-12 reboot, PPP attempt, Ethernet setup (7.54 KB, text/plain)
2001-06-29 11:55 EDT, Bertil Askelid
no flags Details
/var/log/messages for kernel-2.4.3-12 reboot, PPP, Ethernet (19.77 KB, text/plain)
2001-06-29 11:56 EDT, Bertil Askelid
no flags Details

  None (edit)
Description Bertil Askelid 2001-06-25 15:59:11 EDT
At insert of my Xircom CardBus Ethernet/Modem, I get:

   Jun 24 07:25:10 z kernel: eth0: Xircom cardbus revision 3 at irq 11 
   Jun 24 07:25:10 z cardmgr[515]: executing: 'modprobe serial_cb'
   Jun 24 07:25:10 z cardmgr[515]: + modprobe: Can't locate module
serial_cb
   Jun 24 07:25:10 z cardmgr[515]: modprobe exited with status 255
   Jun 24 07:25:10 z cardmgr[515]: module   
/lib/modules/2.4.3-12/pcmcia/serial_cb.o not available
   Jun 24 07:25:10 z cardmgr[515]: executing: './network start xircom_cb'
   Jun 24 07:25:10 z cardmgr[515]: executing: './serial start xircom_cb'

Of course, this prevents my Xircom modem from working at all:

   Jun 24 22:45:04 z ifup-ppp: pppd started for ppp0 on /dev/ttyS1 at
115200
   Jun 24 22:45:05 z kernel: PPP generic driver version 2.4.1
   Jun 24 22:45:05 z pppd[14082]: pppd 2.4.0 started by root, uid 0
   Jun 24 22:45:06 z chat[14096]: Can't get terminal parameters:
Input/output error
   Jun 24 22:45:06 z pppd[14082]: Connect script failed

Because of this, I can't use kernel-2.4.3-12 at all, but have to revert to
the older kernel-2.4.2-2.
Comment 1 Arjan van de Ven 2001-06-25 16:03:38 EDT
The default serial.o should just work. Can you check if this module is already
loaded ?
Comment 2 Bill Nottingham 2001-06-25 16:28:21 EDT
serial.o isn't a module. (it's compiled statically.)

That being said, it should work - it did fine for me the last I checked.
Comment 3 Bertil Askelid 2001-06-25 16:36:50 EDT
No, it doesn't work. There is no module called serial.o. However, I tried with 
   
   alias serial_cb serial_cs

in /etc/modules.conf but it didn't help. Tried generic_serial in the same way.
Still doesn't work.

I get always keep getting "chat[2070]: Can't get terminal parameters:
Input/output error" when I start PPP.
Comment 4 matthew jull 2001-06-29 08:46:15 EDT
i have the same problem - i see complaints at boot up - but i currently use only
the ethernet connection - so i don't know if this will affect the modem.
from /var/log/messages: .

Jun 24 15:12:47 menudo cardmgr[311]: executing: 'modprobe serial_cb' 
Jun 24 15:12:47 menudo cardmgr[311]: executing: './serial start xircom_cb' 
Jun 24 15:12:48 menudo network: Bringing up interface lo:  succeeded 
Jun 24 15:12:48 menudo cardmgr[311]: + /dev/xircom_cb: No such file or directory 
Jun 24 15:12:48 menudo cardmgr[311]: + /dev/xircom_cb: No such file or directory 
Jun 24 15:12:48 menudo network: Bringing up interface eth0:  succeeded 

would be nice to have this sorted out.
thanks
mj-


Comment 5 Bill Nottingham 2001-06-29 10:44:02 EDT
What I'm saying in that it should work is that you shouldn't need to load
*any* module - the compiled in serial driver should recognize the port 
just fine.

What does 'dmesg' say when you load the card (these messages would be
*before* any of the messages from cardmgr)?
Comment 6 Bertil Askelid 2001-06-29 11:55:24 EDT
Created attachment 22226 [details]
dmesg for kernel-2.4.3-12 reboot, PPP attempt, Ethernet setup
Comment 7 Bertil Askelid 2001-06-29 11:56:31 EDT
Created attachment 22227 [details]
/var/log/messages for kernel-2.4.3-12 reboot, PPP, Ethernet
Comment 8 Bertil Askelid 2001-06-29 12:00:48 EDT
I know. I tried the module loading before I saw your reply.

I have attached a complete dmesg and /var/log/messages for a fresh reboot of
kernel-2.4.3-12 followed by an attempt to start PPP, followed by an Ethernet
start.

Everything worked just fine for my Xircom CardBus in 7.0, except for the 2.2.19
kernel.
Comment 9 Arjan van de Ven 2001-07-02 04:36:17 EDT
(2.2.19 kernel has been updated for the bug in the xircom driver)
Comment 10 Bill Nottingham 2001-07-06 00:03:04 EDT
Your config is pointing at the wrong serial port. The xircom
is being detected as /dev/ttyS4, your config is looking for /dev/ttyS1.
Comment 11 Bertil Askelid 2001-07-06 02:08:29 EDT
That did it! Thanks a lot!

I guess that I need to read the /var/log/messages file more carefully. I didn't
expect the selected tty port to change with a new kernel.

You can close the bug: it's not a bug!

Note You need to log in before you can comment on or make changes to this bug.