Bug 459104 - uptime bigger than 900 days
uptime bigger than 900 days
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: procps (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Novotny
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-14 09:57 EDT by Sergio Monteiro Basto
Modified: 2010-03-30 04:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:14:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergio Monteiro Basto 2008-08-14 09:57:31 EDT
Description of problem:

I got 2 machines running since 21 Nov 2005 
ll /var/log/dmesg
-rw-r--r--    1 root     root        25901 Nov 21  2005 /var/log/dmesg

Version-Release number of selected component (if applicable):

Red Hat Enterprise Linux AS release 3 (Taroon Update 4)

procps-2.0.17-13


Actual results:

today uptime say:  14:53:47  up 2 days 

and some processes says 

2009 ?        00:35:24 /usr/sbin/sshd
2009 ?        3-02:50:22 /opt/dell/srvadmin/dataeng/bin/dcstor32d


Expected results:
uptime bigger than 800 .
and ps -ef , with no dates in future .

Additional info:
Comment 1 Albert Cahalan 2008-10-13 02:49:13 EDT
Older 32-bit kernels keep time in a 32-bit value that wraps around.
(this performs better than 64-bit)

The information you desire is thus lost by the kernel.
Comment 2 Daniel Novotny 2010-03-30 04:14:56 EDT
No further updates are planned for RHEL3. As the bug is not present in RHEL4
and higher, we suggest to upgrade to later RHEL release. Closing WONTFIX

Note You need to log in before you can comment on or make changes to this bug.